Nvidia 340xx not working after upgrade to 5.4.8

Every time I try to upgrade my kernel to 5.4.8, my Nvidia driver stops working. When I go to NVIDIA X Server Settings, it tells me to run ‘nvidia-xconfig’ as root. When I do that it writes a new configuration file to /etc/X11/xorg.conf. When I reboot after this Light Display Manager fails to start and my computer sits on "A start job is running for Wait Unt•Synchronized (x min / no limit).

I’m not sure what to do next.

Hello @Scott
Are you using the nvidia-dkms version? Could you post inxi -Fxxxc0

How did you setup the Nvidia 340xx driver? I use it and it works fine with the updated kernel.

To boot and use your system via a terminal for repairs, you probably need to chroot to it.
This should give some help:

I installed the driver from the AUR, I did not install the dkms version. I tried removing that driver and installing the dkms one and now everything is working fine.

In the future I’ll post systemlogs in my posts as well. Thanks a lot for the quick responses!

4 Likes

Welcome to the forum. Thanks for giving EndeavourOS a try. I hope you enjoy your time here.

Looks like you just got a crash course in forum protocol, eh. :wink:

One more thing, if your problem is solved, go to the link that gave the solution and click on the solution Icon. That way the topic is marked solved, and the next user with this problem can go straight to the post that solved this problem as that post will be shown right after the Original Post.

Pudge

Thanks for the warm welcome! I’m loving EndeavourOS so far with the MATE desktop!

Btw., this ancient tool should no longer be used. Instead of write a “/etc/X11/xorg.conf” should be create a .conf-file in “/usr/share/X11/xorg.conf.d/”, e.g. “20-nvidia.conf”. When one really need it.

I think on my install with nvidia-dkms that’s what it did.