Notification area transparency following the inactive window settings

So, it’s time for my first cry for help. :face_holding_back_tears:

I have a problem with my notification area in Xfce. It seems to follow the settings of inactive window opacity, which I deliberately set to 65. Meanwhile, the notification initial opacity is set to 90.
When I hover the mouse on the notification, it remains transparent, even though I guess it shouldn’t.
I checked xfce4-notifyd-config versions for reference - on EndeavourOS the installed version is 0.9.4, meanwhile on Debian-based distros, which don’t seem to have such an issue, the installed version is 0.7.3.

Is there any way to disable xfwm4 transparency of notification area without changing the inactive window opacity?

not sure you can do this in the internal xfce program (xfwm4) let alone something like picom.

Can a setting be tweaked where transparency changes when a mouse hovers over it?
Unless the mouse hover automatically ‘brings it to front’ and I’m not hearing you right.
The mouse makes it go to 65? or no (0) transparency? the only other thing I can think of is some incremental push and pull between the 65 and 90 (test incremental moves up and down by single digits) to see if the hover changes.

Be real curious to see if you can if anyone else can answer this for you. I have similar minor gripes with picom/lxde.

The whole widget’s opacity is set to 65, as that’s what has been set in xfwm4-tweaks. However, the opacity is even lower (90% of 65) when the mouse doesn’t hover the widget.

I hope my explanation is clearer now.

1 Like

I get it. That can be unreadable. Picom differentiates this by changing opacity between an ‘active’ and ‘inactive’ window status just like yours but you have to physically bring the window to the front of the back for them to get the inactive/active statuses…
…but you know all this. The mouse is irrelevant in picom for me–opacity does not change.

So I wonder if you should do your hovering with some window at the forefront? also by notification area you mean a notification widget in the taskbar? that context menu?

The context menu in the taskbar is completely fine, just the widget in the upper right corner of the screen (I didn’t change the defaults here).

Well, I can agree that’s rather a minor incovenience and it’s reassuring to know it’s not only me having such kind of trouble. I just wanted to know if there’s a way to make the widget opaque with the default Xfce compositor. But if not - I guess it’s fine, I can live without it.

Picom should be able to remedy this:

# Window type settings
# 'WINDOW_TYPE' is one of the 15 window types defined in EWMH standard: 
#     "unknown", "desktop", "dock", "toolbar", "menu", "utility", 
#     "splash", "dialog", "normal", "dropdown_menu", "popup_menu", 
#     "tooltip", "notification", "combo", and "dnd".
#   opacity:::
#     Controls default opacity of the window type.
#   focus:::
#     Controls whether the window of this type is to be always considered focused. 
#     (By default, all window types except "normal" and "dialog" has this on.)

dropdown_menu = { opacity = 1.0; };
popup_menu    = { opacity = 1.0; };
utility       = { opacity = 1.0; };
toolbar = { opacity = 1.0; };
menu = { opacity = 1.0; };
dialog = { opacity = 1.0; };
normal = { opacity = 1.0; };
tooltip = { opacity = 1.0; };
notification = { opacity = 1.0; };
combo = { opacity = 1.0; };
unknown = { opacity = 1.0; };
dnd = { opacity = 1.0; };

In this case, you’d probably need to put a setting for “dock”.

Another option is to use a more universal dock/panel like tint2.

I used to use xfce-panel as my universal dock, even in Cinnamon, but some parts/functions of the dock don’t work correctly with some x11 WMs (Bspwm, Qtile, and dk). By using tint2, I eliminated all issues.

Setting the notification value to 1.0 solved the issue.
I might tweak Picom even further since it doesn’t run as smoothly to me as Xfwm4 compositor, but I can live with it.
Thank you!

1 Like

You’re welcome.

Hope you find the right tweaks for your needs.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.