Not getting full internet speed from wifi

I am getting only 2Mbps speed on WLAN although it is 30 Mbps over LAN. Router is set on 2.4GHz (b+g+n) band. What to do pls help.

Hello @nir
This doesn’t help much without hardware information. We have no idea what your WiFi is. Post the output.

inxi -na
1 Like

Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8169 v: kernel port: e000 bus-ID: 02:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: down mac: a4:ae:12:2e:80:d5
Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
vendor: Lenovo driver: rtw_8821ce v: N/A modules: rtw88_8821ce port: d000
bus-ID: 03:00.0 chip-ID: 10ec:c821 class-ID: 0280
IF: wlan0 state: up mac: >

You could try installing this package from the AUR.


Thanks @ricklinux
I have installed and reboot It worked.

Hope it’s better. This rtl8821ce chip is known to have some issues like you mention.

the issue appears again. need further help.

Suggest you buy a new NIC, Intel has always worked pretty well for me.

You could try the rtl8821ce-dkms-git. Other than that i would agree with @dbarronoss it might be better to invest in a WiFi card with known to work well.

You could as well try turning off power saving for WiFi card.

how to turnoff power saving for wifi card

Right. how to disable inbuilt wifi card and use new one.

Did you try rtl8821ce-dkms-git?

Running post-transaction hooks…
(1/2) Arming ConditionNeedsUpdate…
(2/2) Install DKMS modules
==> dkms install --no-depmod rtl8821ce/1.0.5.r130.gca204c6 -k 5.10.90-1-lts
==> dkms install --no-depmod rtl8821ce/1.0.5.r130.gca204c6 -k 5.15.13-zen1-1-zen
==> depmod 5.15.13-zen1-1-zen
==> depmod 5.10.90-1-lts
==> ERROR: Missing 5.15.13-arch1-1 kernel modules tree for module rtl8821ce/1.0.5.r130.gca204c6.

03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter
Subsystem: Lenovo Device c024
Kernel driver in use: rtw_8821ce
Kernel modules: rtw88_8821ce, 8821ce

Any better luck with this package?

No. Is there a possibliity of router fault??
As I switch channel (Auto to 8) in router setting speed come back but after some time issue again appear. Also another windows 10 laptop (rtl8822ce) have same issue.

are you in a heavily congested area? What time of day does the issue happen? If usually at night in a high traffic area thats not too odd.

every time. no matter of heavy traffic

If you have the same issue with another laptop it might be your router or service. I have an HP with this chip and it works okay.