Not booting from USB drive with stable ISO loaded

Bored on a Sunday afternoon, decided to take the plunge and at least try out EOS. Downloaded ISO from Sourceforge (torrent option didn’t work), used dd to create a bootable USB with it, and plugged it into my UEFI laptop. Pressed key for boot options menu, USB doesn’t show up. Only option is Linpus Lite, which takes me into the existing Anarchy Linux install I have on there.

Plugged USB back into my desktop, rebooted, USB was there as an option in boot menu, selected. But the GRUB config I’m familiar with (Deepin and Windows drives for selection) popped up. I turned off fast boot option in BIOS to see if that was the problem, still persisted beyond that change.

Any ideas?

1 Like

Did you make sure secure boot is off?

1 Like

some PC brands have curious BIOS

@ricklinux I find no secure boot option in my desktop’s BIOS, so that’s not the issue. As for the laptop, I seem to have painted myself into a corner so to speak, since when I was setting that laptop up as my main SSH client machine (from which I connect to various other systems) I was looking for ways to make it more secure and apparently put a BIOS access password on, but am failing to find it recorded in the places I would normally retain such information. :frowning:

I was referring to your laptop as you stated you plugged it into your UEFI laptop! As far as the desktop goes is it UEFI or MBR system? If the boot menu comes up it should see it but depending on the type of bios you have and also the brand of usb drive sometimes. On my MBR system there is a + beside hard drive in the menu when you boot a usb with linux on it you have to select that when you go to the boot menu and then inside that another menu shows the usb device and you then select it.

Desktop is MBR, but I’m starting to think the installer drive itself wasn’t right. Changed boot order to explicitly select the USB device, but it gave the standard message when it tries to boot from a nonbootable drive.

I’m rewritting the USB with dd and going to wait awhile after it reports completion just to be sure. If it still doesn’t work, I’ll redownload the ISO.

Rewritten USB drive failed to boot again on desktop, though got a more interesting message:

ISOLINUX 6.04 6.04-pre2-11-gbf6db5b4* EHDD Copyright © 1994-2015 H. PeterAnvin et all
Failed to load ldlinux.c32
Boot failed: press a key to retry…

Pressing a key reboots. So I tried USB drive in laptop next, and this time the USB drive appeared in the boot menu selection, so I chose it, and up popped grub for EOS! Yet too soon to get hopes up: got dumped into a rootfs prompt, indicating a bad superblock on /dev/loop0. Maybe my install media itself is bad. Will try another drive.

Hi!

One thing i noticed specially with my old pc is that some flash drivers don’t work as bootable drivers.
So may i suggest you to try a different flash drive and even a different port in you pc.

2 Likes

Sounds like a fs error. I would clear the usb drive. Download a new ISO and try again. Also as @fernandomaroto said try a different usb and or a different port when writing the drive.

2 Likes

My previous laptop was particular about what USB drives went into what ports when it came to booting. It’s definitely worth a shot if possible.

1 Like

Alright, with a different (newer) USB drive, booted into live environment just fine. However, no touchpad functionality at the moment. Still, able to launch a terminal with Ctrl + Alt + T. So my next goal is to establish touchpad functionality.

1 Like

Yes, @joekamprad already added this to the next version, but 15th july really doesn’t have it enabled.

Ah, good to know @fernandomaroto. When are we expecting the next version to drop?

All developers seemed to agree on releasing a new iso once a month, so possibly 15th august.

2 Likes

@fernandomaroto nice I look forward to it, though in the meantime I’m seeing if I can solve it sooner. Was following this guide:

Went well until I tried the xinput command; zsh says command not found. Before that, I found the name of the device is “ELAN0504:00 04F3:3091 Touchpad”

try adding this file to your /etc/X11/xorg.conf.d

then exit session and see if works (or reboot just in case)

Also check if you have xf86-input-libinput and libinput installed

if for some reason DM stops working you’ll need to acess tty2 and delete the config file :shushing_face:

1 Like

Added file, exited terminal, touchpad not working yet. Rebooting, though wondering if changes to filesystem on live image are persistent. Will I need to install properly to the PC for this to take?

1 Like

Of course not hahaha. I thought you installed it to your pc.
You’ll need to edit that after the system is installed :wink:

1 Like

Alright, attempting install (without touchpad) - let’s see how this goes, heh :slight_smile:

1 Like

i have to leave now, but i wish you good luck.

1 Like