Not booting from USB drive with stable ISO loaded

Hmm, I’m stuck on the partitioning screen where I’ve managed to make my partitioning choices but can’t seem to tab down to the “Next” button to continue to the next installer section. :confused:

Will be away from computers for next several hours - just so anyone replying doesn’t wonder why I’m not responding. :slight_smile:

@fernandomaroto I got through the installation, created the conf file, and rebooted but still no touchpad functionality. Didn’t break anything either as far as I can tell though.

I also verified that xf86-input-libinput and libinput are installed.

Haha, ironically, I realized the touchpad was disabled by default, and simply pressing the function key (F7 in the case of this laptop) associated with turning it on or off was all I had to do to get it working! :rofl:

Now I’m looking at the next challenge: wi-fi. When I click the network icon in the tray, under Wi-Fi Networks it says “device not managed.”

3 Likes

Make sure the wifi is turned on. :wink: Try systemctl start NetworkManager.service

1 Like

What wifi chip is it?
lspci

It was turned on; pressed function key for that, said disabled. Pressed again: “device not ready.” Tried the systemctl command you suggested, still saying either “device not ready” or “device not managed.”

Intel Corporation Device 3198 (rev 03) is the network controller.

Post this command.
lspci -k

I don’t see wifi on there . Does it have ethernet? The Intel looks like Ethernet port. Do you have inxi installed?
Run inxi -Fxxc0 which will show all hardware.

There’s definitely no ethernet port on this machine, it’s very slim. Bash says inxi command not found.

So you don’t have it installed. Try lsusb. It’s possible it’s the Intel Device 31dc.

You could try installing linux-headers and then reboot. It won’t hurt anything.

sudo pacman -S linux-headers

Reboot

Tried to install linux-headers, got warning from pacman that it was reinstalling it, then a bunch of errors not finding a source (no network connectivity yet, after all). Rebooted, no noticeable changes.

If you don’t have a network connection then you can’t install it. If it said trying to reinstall it must already be installed anyway.

It may be.

systemctl restart NetworkManager

My guess at this point is that the service is fine but the interface isn’t configured right or something. The systemctl commands don’t seem to change things. Tried ip link and see that wlp0s12f0 (wi-fi card) is in state DOWN.

It may not have the module loaded for the chip. I just can’t tell what chip it is from the info. It’s not really identifying it to me.

I hear ya, and I geniunely appreciate your efforts to help. I think I’ll pick this back up tomorrow, since I should get to sleep so dragging myself into work tomorrow isn’t more difficult than it has to be. :slight_smile:

Did you try sudo ip link set wlp0s12f0 up