Noise Suppression for Microphone

Hey homies,

after a long time of dualbooting, I finally decided to go EndeavourOS fulltime, since almost all my games do work as well (sometimes even better than on windows, lol) happy clap.

Anyway I am facing a huge issue right now. I do have to participate in a lot of online lectures/meetings for college (lecture, being a tutor and stuff). Sadly my microphone is having some noise to it and I have no idea why. In comparison, on windows, there wasn’t any noise at all, or if, it was very very soft. Especially since I am using a RTX 2060, I was able to use NVIDIAs Broadcast to suppress any noise at all.

Sadly the noise these day is enough, that people get mad at me. I am using a Sennheiser Game ZERO, which actually has a pretty good mic.

I found some solutions like NoiseTorch, but as far as I know Arch does use Pipewire these days, hence this plugin does not work (since it’s for PulseAudio).

Any recommendations? It’s making me sad. I definitely have to improve this situation, but I am too noob to know how… :frowning:


1 Like

NoiseTorch is amazing piece of software! :partying_face:
Saved me some health while talking with my colleague who have 2 small children…I forced him to use NoiseTorch :laughing:

It’s not a problem, should work when you install pipewire pulse brdige:

sudo pacman -S pipewire pipewire-pulse --needed

Then you just:

  1. Open NoiseTorch set noise suppression levels and use load / reload buttons
  2. Choose NoiseTorch microphone in given program, or on system level

That’s the spirit!:partying_face:
BREAK YOUR WINDOWS!!! :facepunch:


It works absolutely flawless, right out of the box, with less install and adjustment pain than with NVIDIA broadcast. I am absolutely impressed, holy crap.

Thank you so much! :hearts:



I did!


Also be careful with NoiseTorch, especially if you change settings while talking and during a call. Trust me, you will unleash angry demons for a few seconds.

1 Like

Yeah you’re right, but that’s some real :ghost: in a shell, for example when i tweak it - nothing bad happens, but when my colleague do - call program loose sound until it’s rebooted :thinking:

No idea why it’s different, but better tweak before call, to be on a safe side :upside_down_face:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.