"node: error while loading shared libraries: libicui18n.so.73: cannot open shared object file: No such file or directory" error

So I was using discord_arch_electron for a long time now, and during an update I saw this error. I decided to uninstall the package and reinstall it again but the error showed up again.
I have to use the default discord package for now which installed properly without any issues, but any other discord package that contains a newer electron version is broken and the same error mentioning “libicui18n.so.73” shows up.

Is that an issue on my end? Any way to fix it?

Uninstall again, delete it from the yay cache ~/.cache/yay/discord_arch_electron and reinstall (or you could just cleanbuild it). Will try it here now.

:Edit: Just installed discord_arch_electron, works fine.

Sadly not working, I’ve tried cleanbuilding. The same error occurs :confused:

Had a similar issue with megasync. Installed cui73-bin package until megasync updated their package to use cui74 (current).

Sorry for brief answer. Currebtly on mobile. No EOS to check. :wink:

where can I find this package?

sorry. back on laptop I checked again

icu73-bin is the name

icu stuff now has 7.4 version and might break other packages that still need 7.3.


ohh okay this seems to be working, thank you!!!

1 Like

icu73-bin worked for me as well, I ran into the issue with webcord.