No WiFi on Live USB (TP-Link Archer T2U Plus)

I found this topic which had issues with this WiFi adapter.

But I need it to install EOS, how can I do it?

The problem is it says “not connecting to a wifi until reboot”, but I cannot reboot because its Live USB. And I need internet access to be able install Plasma.

How to fix this?
P.S. Maybe this is fixed in new EOS installation mine is like 3-4 months old.

You seem to have a lot of trouble with your wifi, I have seen a couple of your threads about wifi now.

Using a wifi card that does not work after boot means it is most likely proprietary garbage and not implemented in the kernel. It’s irritating for sure (recently had some wifi driver hate experience), but in the long run it may not be worth trying workarounds that may break later. My recommendation is to buy a pci wifi, costs about 30 bucks and make sure it is supported in Linux…

The above link says that you need to install a driver from the AUR using yay. Meaning you need an Ethernet connection anyways to install the driver.

Can’t I just download files from other computer and then install that way?

If the package has any other dependencies and wants to pull some additional packages via git it’s going to be messy. Dealt with it before, what was supposed to take 5min took 2 hours and was still not working. This could turn into a 100 post thread without fix.

However someone can guide you through how to install packages downloaded offline. Don’t mean to discourage you. Speaking from own experience I would go pci…

That is not the issue I can go “hard way” if it is really needed.
I’m just not sure I should go this rabbithole downloading manually packages etc if in the end all that stuff needs restart to start working…

Well in your case you need to first install eos offline, then copy your package via USB stick from AUR to computer and install via yay and reboot. You will not be in the live iso…


Yes seems like that, I will wait a bit maybe someone inputs another way to deal with this before I proceed. :face_with_monocle:

But looking at your package it will try to pull from GitHub, without internet not possible I think unless you clone manually from another computer and change the build package. Good luck! Think about my words pci supported by Linux and avoid the frustration :wink:

You could try this and see if it works:

Put the package you want to install in live session on another USB drive.
In live session open the file manager and go to where you saved the package earlier.
Open a terminal there and run sudo pacman -U X ## where X is the name of the package.

Another option would be to USB-tether your mobile phone and see if you can get online that way. If you can then you can do an online install.


Yes but as I understand this is the package I want will there be huge problem with dependencies?

bc (bc-gh)
git (git-git, git-vfs) (make)

I feel like this will need A LOT stuff :thinking:

It might. I wouldn’t know without having tried it myself.

You might want to try to USB-tether your phone.

1 Like

Those dependencies are needed for building the package. For installing, this is what you get:

sudo pacman -U rtl88x2bu-dkms-git- 
[sudo] password for pebcak:          
loading packages...
resolving dependencies...
looking for conflicting packages...

Package (1)         New Version             Net Change

rtl88x2bu-dkms-git   26.32 MiB

Total Installed Size:  26.32 MiB

:: Proceed with installation? [Y/n]

No other packages seem to be needed.

1 Like

Could you do installing using the USB tethering?


1 Like

Do you have the same WiFi chip? Can you post the output

inxi -Na

Just wanted to see what chip the USB WiFI adapter has. Which realtek is it?

[elnath@elnathPC ~]$ inxi -Na
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
           vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel modules: r8168 port: f000 
           bus-ID: 06:00.0 chip-ID: 10ec:8168 class-ID: 0200 
[elnath@elnathPC ~]$

I connected Ethernet cable and did yay -S rtl88x2bu-dkms-git then restart, but for me it didn’t work. No Wifi. @ricklinux

What WiFi device did you buy? The output from that command is strictly the Ethernet port. Did you get a WiFi card?

The one in title - TP-Link Archer T2U Plus. It is USB WiFi adapter.

[elnath@elnathPC ~]$ lsusb
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 002: ID 2357:0120 TP-Link Archer T2U PLUS [RTL8821AU]
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 001 Device 004: ID 0b05:1939 ASUSTek Computer, Inc. AURA LED Controller
Bus 001 Device 003: ID 046d:c332 Logitech, Inc. G502 Proteus Spectrum Optical Mouse
Bus 001 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[elnath@elnathPC ~]$ 

Is it a USB type?