No terminal will open after system update

I just did an update, and now I can’t seem to allocate any pseudoterminals. I can open everything else (read: everything graphical). I’ve tried multiple window managers, and my fallback kernel. Any ideas?

My post in Superuser:

Can you post system logs:

3 Likes

Must not have been a proper update? Partial? :thinking:

2 Likes

Can you still drop to a tty?

Are you use bash? fish? zsh?

1 Like

The solution will most likely involve entering terminal commands. You might be able to get a fullscreen terminal by holding the keys CTRL + ALT + F2. To switch back to the desktop hold down CTRL + ALT + F1

edit:
Xfce: ALT + F2 ?

Unfortunately I don’t know the solution to this problem.

Superuser link shows Cinnamon and Xfce installed? Not a very clear picture of the problem. :man_shrugging:

Have you tried to login from TTY as mentioned above by @mrvictory.

If you can, then you could run the commands from there.

Edit: sorry @mrvictory and @Melways I saw the M and … :blush:

The SU link (which I should’ve also mentioned here) says that all of my WMs experience the problem, including both XFCE and Cinnamon. Cinnamon, though, specifically shows a spinning mouse icon when I click on my Terminal link (the rest of the WMs just seem to ignore my invoking the terminal completely).

Sorry!
My bad!
Try logging in from TTY as stated above by @Melways.

It’s OK - I don’t mind being known as Mister Victory :rofl:

2 Likes

My thinking was that if you can get a terminal in Xfce via ALT + F2 then after logging in there you could:

sudo pacman -S xfce4-terminal

Maybe you had 1 terminal emulator across desktops that somehow where uninstalled.

What is ALL of your WMs? What’s installed? Multiple desktops?

1 Like

Done via an SSH session, but no difference.

A TTY (teletype) terminal, not a ptty/pseudoterminal.

Yes, BASH.

My point is that it’s window-manager agnostic. It’s happening everywhere. XFCE and Cinnamon (mentioned in that same comment), and Gnome.

Thanks for all of the responses.

It’s not an application problem, it’s presumably a pseudoterminal problem in that I can’t open a terminal window in any sense, though I can open an SSH session to myself, which seems like a paradox. Normal terminals work fine.

I’ve replaced the original Superuser post with this one, which is specific to it being a pseudoterminal anomaly:

As requested directly/indirectly above, this is my journalctl output:

https://tinyurl.com/yujz328t

I didn’t see any present/useful Xorg/X11 logging even though this is also, arguably, an X11 problem.

is selfdestroyed already …

Thanks. I’ve fixed it there, but here it is, too:

https://tinyurl.com/yujz328t

May 22 15:46:25 dustinxps /usr/lib/gdm-x-session[5863]: /usr/bin/xfce4-terminal: error while loading shared libraries: libicuuc.so.70: cannot open shared object file: No such file or directory

Try reinstalling:

  1 core/icu 71.1-1 [installed]
  2 extra/harfbuzz-icu 4.3.0-1 [installed]
  9 multilib/lib32-icu 71.1-1 [installed]

:edit: it is looking for 70, 71 is the current, looks like a partial upgrade, either ssh or chroot in and try and update.

1 Like