No sound on fresh install have tried everything i can find

Hello everyone, i have just installed endevourOS again on my new notebook, but the system does not seem to be picking up the built in sound system or devices i plug into it.


Can you output some system infos?

$ inxi -F

So we know which kernel, DE, soundcard driver etc.

Welcome back :grin:

thanks friend i have run this and this was the output

  Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    Desktop: KDE Plasma v: 5.26.0 tk: Qt v: 5.15.6 wm: kwin_x11 dm: SDDM
    Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: Razer product: Blade Stealth 13 (Late 2020) -
    RZ09-0327 v: 5.04 serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: Razer model: LY350 v: 4 serial: <superuser required> UEFI: Razer
    v: 2.03 date: 03/29/2021
  ID-1: BAT0 charge: 51.4 Wh (100.0%) condition: 51.4/53.4 Wh (96.3%)
    volts: 12.9 min: 11.6 model: Razer Blade serial: <filter>
    status: discharging
  Info: quad core model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP
    arch: Tiger Lake rev: 1 cache: L1: 320 KiB L2: 5 MiB L3: 12 MiB
  Speed (MHz): avg: 896 high: 1298 min/max: 400/4700 cores: 1: 400 2: 523
    3: 1023 4: 1153 5: 1010 6: 513 7: 1298 8: 1255 bogomips: 44851
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Razer USA
    driver: i915 v: kernel arch: Gen-12.1 ports: active: eDP-1 empty: DP-1,
    DP-2, DP-3, DP-4 bus-ID: 00:02.0 chip-ID: 8086:9a49
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: Razer USA
    driver: N/A arch: Turing pcie: speed: 2.5 GT/s lanes: 4 bus-ID: 59:00.0
    chip-ID: 10de:1f95
  Device-3: IMC Networks Integrated Camera type: USB driver: uvcvideo
    bus-ID: 3-6:2 chip-ID: 13d3:56d5
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: intel unloaded: modesetting alternate: fbdev,vesa dri: i965
    gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96
  Monitor-1: eDP-1 mapped: eDP1 model: Sharp LQ133M1JW46 res: 1920x1080
    dpi: 168 diag: 337mm (13.3")
  OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 22.2.1
    direct render: Yes
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Razer USA
    driver: sof-audio-pci-intel-tgl bus-ID: 3-3:7 chip-ID: 0ecb:203a
  Device-2: JBL Quantum One type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
    chip-ID: 8086:a0f0
  IF: wlan0 state: down mac: <filter>
  Device-2: ASIX AX88179 Gigabit Ethernet type: USB driver: cdc_ncm
    bus-ID: 2-1.1:3 chip-ID: 0b95:1790
  IF: enp0s13f0u1u1c2 state: up speed: 100 Mbps duplex: half mac: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:4 chip-ID: 8087:0026
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Local Storage: total: 931.51 GiB used: 148.15 GiB (15.9%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 980 1TB size: 931.51 GiB
    speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 32.9 C
  ID-1: / size: 204.69 GiB used: 16.69 GiB (8.2%) fs: btrfs
    dev: /dev/nvme0n1p1
  ID-2: /boot/efi size: 96 MiB used: 29.4 MiB (30.6%) fs: vfat
    dev: /dev/nvme0n1p6
  ID-3: /home size: 204.69 GiB used: 16.69 GiB (8.2%) fs: btrfs
    dev: /dev/nvme0n1p1
  ID-4: /var/log size: 204.69 GiB used: 16.69 GiB (8.2%) fs: btrfs
    dev: /dev/nvme0n1p1
  Alert: No swap data was found.
  System Temperatures: cpu: 50.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 263 Uptime: 10m Memory: 15.39 GiB used: 4.04 GiB (26.2%)
  Init: systemd v: 251 default: graphical Compilers: gcc: 12.2.0 Packages:
  pm: pacman pkgs: 1074 Shell: Zsh v: 5.9 running-in: konsole inxi: 3.3.22

1 Like

Would also have to do some search. Have been dealing with audio issues lately, my knowledge is little in that area. But found on arch wiki that on other razer laptops it requires the following package for built in Intel audio.

Maybe worth a shot? If not already installed.

sudo pacman -S sof-firmware

i just tried that made didn’t do anything, i remember i sorted it once but i cant remember i just remember adding some lines in a config file but that was ages ago

Just make sure to reboot if you try that. I also note that you didn’t install yet the Nvidia driver. Let me know if you need any help with that…

i did, when i said i tried everything i really did try everything.

Looks like additional steps are need after install of that frimware.

Perhaps do it step by step, first blacklist other audio modules. They list many steps and not sure it is all necessary.

thank you, ill give this a shot and see if it works internet is slow so it will be awhile before i get back to you.

Why in the hell you’ve asked inxi without -z flag?! :man_facepalming:
nobody needs to see their personal info or hardware mac address flying around.

Should be:

inxi -Fz

you might want to redact your post…

1 Like

Some people just don’t know what they’re putting into the terminal - maybe something someone could write up a guide on (not me though - I’ve been trying to put together a simple tutorial for months now on how to customise plasma splash screens and everytime I re-read & try following what I write it’s just no good)

1 Like

Like that?


1 Like

better to use something like:
inxi -Fxxc0z --no-host

for not showing Private data please :wink:


I’m way to drunk & have had to deal with buliman and all today to read anymore than a few lines - but all in all if you don’t explore what the command you are inputting it’s on you - basically though just look at what info the command has grabbed & if it’s anything that’s identifying or you arent sure ask. If I wasn’t so off my head I’d give a better example - I’m not even sure if this makes sense more worried about my brother right now & the buliman

Exactly lol, the first command posted stops this issue happening - if I was sober I’d post more but I can barely make sens of anything let alone the keyboard strobing lights as me now

1 Like

--no-host seems redundant:

--no-host Turn off hostname for -S. Useful if showing output from servers 
           etc. Activated by -z as well.

Not on purpose… Will have to edit my recent posts, didn’t pay attention :man_facepalming:


yes i saw this also already :wink: but forget about it again… its in the wiki… because a user recommended the command one day in the far past…

1 Like

Nah not of that worked. dunno what else to try. my USB headset and Bluetooth headset still work at least, but the built in speakers don’t work and anything i plug into the sound card wont be recolonized

I have also updates my inxi post

and sorry for not replying sooner uni had me on my feet all day