No sound from speakers on fresh install

I have a Dell xps 17 running Atlantis gnome. The speakers do show up both in sound settings and in pulseaudio volume. The microphone does not show up at all.

I can say I have had EOS before, with the August ISO. Everything worked out of the box that time, and updating to pipewire later did not cause problems either.
https://clbin.com/9kMPo

Have you tried unplugging the speakers and plugging them in again?

would if I could, its the internal speakers
*edit should have mentioned it. Also they work fine in windows

Sorry i didn’t notice is a laptop. :grinning_face_with_smiling_eyes:

Did you install

sof-firmware

driver: sof-audio-pci-intel-cnl

sudo pacman -S sof-firmware

Edit:

Audio

This laptop requires firmware from the sof-firmware package in order for the internal sound card to work. Also see Advanced Linux Sound Architecture#ALSA firmware.

Its actually preinstalled, but I have tried to reinstall, remove and install etc…

1 Like

It does need sof-firmware installed and reboot.

I was on the April .iso, but manually changed PulseAudio to Pipewire since that’s now the default and I don’t want to be left in the dust! I had one or two quirks with Pipewire output configuration, but between laptop speakers, bluetooth UE Boom speaker, and Samsung Galaxy bluetooth earbuds, everything does work on my end. Here’s my current sound setup, perhaps you might need to select a different ‘configuration’ ?

No wonder it doesn’t work. It’s Gnome! :laughing:

:innocent:

Edit: I don’t like brocolli! :nauseated_face:

2 Likes

Haha I actually tried an install with sway first, but that was just even more hazel…

I like Sway…but Wayland…? It’s great when it works but for the most part I’d rather not bother.

2 Likes

I remember that it looked like that before! how did you get the “volumes levels” tab? Bluetooth, headphones, usb c headset etc works. Only thing that does not work is the internal speakers and microphone.

If you have sof-firmware installed then it’s probably a configuration issue.

@Scotty_Trees is the Gnome expert!

I wish I was not addicted, got it without knowing it when I installed arch for the first time. Accidentally used x11 and it was dreadful…

X is awesome …again when it works right! :wink:

The volume levels tab shows up whenever you have anything open that uses sound, for me that’s currently Vivaldi (displayed as chromium), gnome podcasts app, and Rhythmbox open which is currently playing music. System Sounds should always be there by default, if you don’t at least see that, then you might be missing a crucial package. As for the microphone, that should also be displayed by default. Your Dell XPS 17 was released back in May 2021, so the hardware “should” be support by the kernel by now, but it’s possible you might want to test the LTS and ZEN kernels via EndeavourOS akm app just to see if this is more a kernel issue than anything else. What kernel are you on now?

Edit: nevermind I forgot to check it: Kernel: 5.15.8-arch1-1 x86_64

What is your current audio status show?

inxi -Aa

Hopefully theirs looks like mine:

[scott@endeavourOS ~]$ inxi -Aa
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
    chip-ID: 8086:9d71 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.8-arch1-1 running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.42 running: yes
[scott@endeavourOS ~]$ 

I’m not an expert, I just enjoy suffering :slight_smile:

Do you have a Dell too?

Edit: OP’s hardware output shows alsa and pipewire so should be.

Clicking on my username shows my hardware and software, for future references :wink:

1 Like