No samba after fresh install

After fresh install and following this guide, I seem not te be able to get samba to work.

[eljejer@spectre ~]$ sudo systemctl start samba smb nmb
[sudo] password for eljejer:
Job for nmb.service failed because the control process exited with error code.
See “systemctl status nmb.service” and “journalctl -xe” for details.
Job for smb.service failed because the control process exited with error code.
See “systemctl status smb.service” and “journalctl -xe” for details.
Job for samba.service failed because the control process exited with error code.
See “systemctl status samba.service” and “journalctl -xe” for details.
[eljejer@spectre ~]$

The fore mentioned details are not very enlighting to me either :slight_smile:
Please help. Thanks

Here’s my smb.conf

Is this bug affecting my problem?

samba version 4.11.3 is broken with python 3.8. so it may is the issue …

Now I downgraded from 4.11.3 to 4.11.2 (samba, libwbclient, smbclient and ldb) and still not starting
Further advise is much appreciated

run
testparm
to check for syntactic errors

Got errors out of testparm (maybe gone wrong copy- and pasting).
Written new smb.conf file and now testparm result is ok
Still same (?) error starting the service

Also, I must have missed a step in the guide (under Xfce): yay -S system-config-samba.
Executing this now gives an error in building pygtk package: ==> ERROR: A failure occurred in build().

pango.c: In function ‘_wrap_PangoFont__do_find_shaper’:
pango.c:3822:32: error: ‘PangoFontClass’ {aka ‘struct _PangoFontClass’} has no member named ‘find_shaper’
3822 | if (PANGO_FONT_CLASS(klass)->find_shaper)
| ^~
pango.c:3823:38: error: ‘PangoFontClass’ {aka ‘struct _PangoFontClass’} has no member named ‘find_shaper’
3823 | ret = PANGO_FONT_CLASS(klass)->find_shaper(PANGO_FONT(self->obj), lang, ch);
|

make: *** [Makefile:630: pango_la-pango.lo] Error 1
==> ERROR: A failure occurred in build().

Edit: it seems pygtk is not maintained any more. Do I have to install system-config-samba as per the instructions?

Samba 4.12.0 is out on testing. Some old hardware will need you to activate smb v1 protocol.

See this message on arch-general mailing list: https://lists.archlinux.org/pipermail/arch-general/2020-March/047604.html

no this is only to have a tool for managing it, but it is also not that easy to use…
I do not use samba anymore i switch to nfs, more easy to configure and working nicely…

Hi,
Turns out I do not need samba afterall :slight_smile: I just presumed I needed it to see network drives in Thunar, but it turns out Thunar accesses samba network drives without explicitly installing samba on the laptop.
Thanks anyway.

Hi Hi… i was thinking about asking you what for you want to create a samba server at all, but i was presuming that you know what you need.

And yea if you only want to use a samba server as a client you do not need to set all this up…

I always wonder why people still use samba instead of of using ssh.
What SMB protocol do you use?
SMB 1 was deactivated per default in samba version 4.11. SMB 2 ist used.
The following link is also important, if you do a version downgrade.

samba release notes

Yes, I have been wanting to setup NFS on my file server (also arch linux) again. I remember that, when I was still on a Windows client, client/server filehandling was much smoother using NFS than it was with SMB. Do you know if Thunar supports this as well or can you recommend another file manager for this?

Thanks for your input. I can refrain from installing samba after all because Thunar supports it natively it turned out

Hello… :vulcan_salute:
I had the same issue and Samba would see the network but could not connect to anything… I tried the “downgrade” in this thread and it did not work for me. I found this article ( https://www.youtube.com/watch?v=8mv7PZGzWnA ) and it worked for me. I applied this to all of my “smb.conf” without downgrading and everything works again.
I add this to my “smb.conf” and the network started to work as before…

Edit /etc/samba/smb.conf and add

client min protocol = NT1
server min protocol = NT1

to the global section to restore workgroups and SMB1
-- 
David C. Rankin, J.D.,P.E.

I hope this helps someone else that is having issues with there Samba Network… :alien:
LLAP

It is a dead-end. In Samba 4.12+, SMBv1 support will be removed slowly.

Too bad some hardware cannot be upgraded to SMBv2.

https://lists.samba.org/archive/samba/2020-April/229108.html

This isn't a good idea really and is only a stop gap, Samba is working 
to remove SMBv1 entirely.

So… :frowning:

@FredBezies thanks! The whole thing just sucks, if it’s working leave it alone!
LLAP