No response on ADB devices

cmd like adb version works well but other cmds of adb are not working
All of them gets stucked and doesn’t provide any response…

Well all the things that are needed are already installed like
but still there is no response in the cmd adb devices, adb kill-server or start-server.

Screenshot from 2024-01-11 12-26-16

you did turn on USB debugging on the device right?

Yeah, all of it is working well

When I try adb devices it doesn’t provide any response

Is your adb deamon running?

%_ ❯ adb devices           
* daemon not running; starting now at tcp:5037

There is no response here
It gets stuck and the cursor is always blinking

Screenshot from 2024-01-11 12-26-16

what happens if you kill the server and restart it?

Unplug the device, enter adb devices. wait until the deamon starts, plug the device back in and repeat the step

If this does not help, there must be something wrong with your device. Then you should check usb-debugging again as described by @thefrog

I hope this helps

adb kill-server is also not responding same as adb devices

Tried all of them
Don’t know what might be the reason but only adb version is working and other cmds anre not responding
I have tried it with other devices also, but the issue persists

is the device viewable in a Filemanager?

do you have another cable to use?

Yes, it is on file manager the cable is working fine.
Sir, does the path of the adb can give issue ?

I think the adb is installed in /usr/bin or it should be inside android SDK ?

[diyash@diyash-nitroan51555 ~]$ adb version
Android Debug Bridge version 1.0.41
Version 34.0.4-android-tools
Installed as /usr/bin/adb
Running on Linux 6.6.10-zen1-1-zen (x86_64)

I never install android-sdk only android-tools which i belive has been renamed to android-utils anyway the only tool i use is adb for weekly backups of my phone.

however even adb devices with nothing plugged in should give some output


Mine is not responding even i have device plugged in or not.

Really frustrated sir is there any way to solve this issue

Dont know what might me the issue

have you done a reboot and tried?

everything :sweat_smile:

I just realized your on the zen kernel i’m not sure if that would make a difference or not. However since I’m on the regular kernel and it works i would suspect its something to do with the zen kernel

Well it was working file before i updated my distro but after update don’t know what happened.

Thanks @thefrog for your precious time, you might get frustrated as well :sweat_smile:
I will solve it no matter what

1 Like

I would say try it out on the lts kernel and see if its working. since i know nothing about zen kernel i’m of no use there.

I m a nwebie don’t know to how switch kernel :laughing:

typically you would want to install like so

pacman -S linux-lts linux-lts-headers