No option for wayland sessions

No option for wayland sessions
The gnome option is an x11 session by the way

for those who want specs

I don’t use GNOME myself, but I guess since Wayland is the default in GNOME that it is also just referred to as GNOME when selected. X11 is then the alternative.

For plasma you need to install plasma-wayland-session

That is not Gnome on wayland though, its still x11

i have done that already and it doesnt show up

So you have two X11s to choose from? Strange …

why do you have both gnome and plasma on the same system? that’s a recipe for disaster

1 Like

nah they work fine, only problem is having to change themes every time i switch

Have you rebooted?


To enable the choice of Wayland, make sure the comment is on the following line in /etc/gdm/custom.conf:


Alternatively, you may be able to change the line to:


Do you use Nvidia?

Posting some system infos might help…

1 Like

Gnome should be running Wayland by default. Please provide install logs/journal logs so we can see what went wrong on install or what you removed too get there.

yeah i use nvidia, changed main post to have list of specs

I have that commented so ill see if anything changes if i make it true

What does


say when you log in to Gnome session?

gaming123@gaming-machine ~  echo $XDG_SESSION_TYPE
gaming123@gaming-machine ~ 

Can you try starting a Wayland session manually?

gnome-shell --wayland

1 Like

had to do it from tty, its not convenient but it works

At least we know now that you can run GNOME on Wayland.

Why it doesn’t show as an option in the login screen?
I don’t really know.

Does it have to do with Nvidia?
I don’t have Nvidia graphics. I believe there are some forum mates who run GNOME-Wayland with Nvidia. They might be able to shed some more light on this.

Could you post:

cat /lib/udev/rules.d/61-gdm.rules


Copy the output as text, paste it in your reply, highlight it and press Ctrl-E.