No option for online installation

I can’t use the online installation in live cd in China, it will show that I can’t connect to the network, but the network is open and there is no problem

What mirrors are available in China?

If your live environment cannot connect to Arch & EndOS mirrors then an online install is impossible.

try to use “update mirrors” from welcome before starting install, and make sure it detects a good amount of mirrors, there are around 15 archmirrors in China and we have one for EndeavourOS there:

## China
Server = https://mirrors.tuna.tsinghua.edu.cn/endeavouros/repo/$repo/$arch

Check if you can open the mirror webside:

And if it shows a warning that you do not have a network connection give us the hardware details, as it could be also driver for the networkcard is not working good:

inxi -N

1 Like

This is the NIC information

Network:   Device-1: Qualcomm Atheros Killer E2500 Gigabit Ethernet driver: alx 
           Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
           driver: ath10k_pci 

I’ve added the Chinese source and it has no effect

using wired or wireless connection?
And is internet working on browser?
So can you open the chinese mirror website on Live-Session?
can you ping chinese arch mirrors?
per example:
ping mirrors.hit.edu.cn/archlinux

If possible give the boot log from Live-ISO:
journalctl -b -0 | eos-sendlog (will work if you have internet connection)

  1. Both wired network and wireless network are available and connected normally.
  2. The browser accesses the network normally.
  3. I can open the Chinese mirror site on live-session
    I found that if I hook up vpn, I can install the system online normally, does it mean that the online of endeavouros is not accessible for China?

could you try to do package install from live session?
sudo pacman -S htop
p.e.
and
sudo pacman -S akm
to check endeavouros mirrors

It can be that mirrors getting blocked, but as we have chinese mirrors for arch repos and also one for EndeavourOS repo it should not be that.

For arch repo mirrors you can set mirrorlist on livesession to only hold chinese mirrors, as this will be used for install process… issue could be that one or more mirrors from endeavouros-mirrorlist are blocked at your place… as they come from package and there is no way to edit it prior install …

But if this is true we can fix this, by editing eos mirrorlist to set tuna mirror on top or may only if installing from china

I’ll try it out and give feedback on the results later.

I just tested htop and it can be installed .
Feedback from akm is as follows

Package (1)      Old Version  New Version  Net Change

endeavouros/akm  2.8.8-2      2.8.8-2        0.00 MiB

Total Installed Size:  0.02 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring                               [--------------------------------] 100%
(1/1) checking package integrity                             [--------------------------------] 100%
(1/1) loading package files                                  [--------------------------------] 100%
(1/1) checking for file conflicts                            [--------------------------------] 100%
:: Processing package changes...
(1/1) reinstalling akm                                       [--------------------------------] 100%
:: Running post-transaction hooks...
(1/3) Arming ConditionNeedsUpdate...
(2/3) Checking which packages need to be rebuilt
(3/3) Updating the desktop file MIME type cache...

I think the problem may be that the location is blocked, after all, I just need to use vpn to install all the problems can be solved, but after installing the system if I cancel the vpn connection, the system just keep reminding me through welcome to the endeavour that there is no network connection, but actually my network can be used normally.

this could be also simply caused by the URL used to check internet connectivity…
@manuel could give the info faster than me…

What’s the output of

eos-connection-checker && echo OK || echo Fail

And you might want to check the contents of /usr/bin/eos-connection-checker, do you have any ideas for it?

I have checked the content, I do not see any problems, the links inside I have also tested, can be accessed normally

So how to solve this problem?

it gives you ok?

As you say using VPN works and do not give the not network error?
We could set endeavouros-mirrorlist to have the chinese mirror on top and commenting the GitHub mirror inside as GitHub is known to be blocked in China.

But we need to implement this first as it will need to detect that you are installing from China (other countries could be added where blocking happens) and if positive changing the endeavouros-mirrorlist.

I’ve tried putting china-mirror at the top and refreshed the list, but it still tells me: no network link

We use eos-connection-checker in the beginning of the install, and if that fails, install fails.

So this is an important question. Please show the output of this particular terminal command, exactly as it is.

Already posted

#!/bin/bash
#
# Checks that an internet connection exists.
# Return value is 0 on success, or another number on failure.
#
# Example usage:
#    eos-connection-checker && echo connection is ON
#    eos-connection-checker || echo connection is OFF

Main() {
    local eml=/etc/pacman.d/endeavouros-mirrorlist
    local default=https://duckduckgo.com
    local url="$default"

    if [ -r "$eml" ] ; then
        url="$(/usr/bin/grep "^Server = " "$eml" | /usr/bin/head -n 1 | /usr/bin/awk '{print $3}' | /usr/bin/sed 's|/$repo/$arch$||')"
        case "$url" in
            https://mirrors.tuna.tsinghua.edu.cn/endeavouros/repo) ;;
            *) url=$default ;;
        esac
    fi

    /usr/bin/curl --silent --fail --connect-timeout 8 "$url" >/dev/null
    return $?
}

Main "$@"

I’m interested in the output of this command, not the source code.
For example:

  $ eos-connection-checker && echo OK || echo Fail
  OK

OK, thanks!
So that reassures that eos-connection-checker is not failing. Then the reason must be elsewhere. Blocking may be the reason.

There must be other Chinese users with the same issue? If so, does anyone know a solution (other than vpn)?