No mobile broadband internet connection

greetings fellow users, i have come in great need once again.

i wanted to do reinstall endeavouros.
i was doing the usual install in tandem with the described method in LiveUSB Mobile broadband - #8 by anon3337769

However the modem does not seem to connect, it is recognized via the file manager, but the network is unable to connect (it worked in the liveinstall via the linked method)

In few cases, turning on USB debugging mode in mobile helps to solve this problem.

Alternatively,

https://bbs.archlinux.org/viewtopic.php?id=245615

This topic helps in solving related issue.

If you want to solve in another way, then

i think there is a misunderstanding, i am talking about a usb broadband internet stick mentioned in the linked post.
Connecting to a phone works perfectly fine, this is how i am able to write as of this moment.

Ah, OK.

Is output of lsusb showing your dongle as mass storage device ?

According to the article which is shared by you, the solution consisted of few packages, importantly usb_modeswitch.

In one of the conversation on Ubuntu forum, the idea was to reinstall this package.
The latest version is usb_modeswitch 2.6.1-2 . If you install(re) and reboot the device then it should be solved.

Then why not unmount it first via file manager, then follow those steps given in your link ?

In Arch Linux Wiki, I found this :

ModemManager does not recognize the modem

In case ModemManager does not recognize the modem, check the unit status of ModemManager.service. If you get error messages such as Couldn't check support for device and not supported by any plugin, you may have to whitelist your device using the ModemManager filter rules.

i did try reinstalling all mentioned packages, it didnt work.

In the end i did wipe and install once again, for now it seems to work, im assuming a package or other was funky.

2 Likes

Also,

$ systemctl start NetworkManager
$ systemctl enable NetworkManager

doing this can also help out as sometimes this is disabled by default.

1 Like

ill be sure to keep this extra step in mind in the future, thank you.

the problem has resurfaced yet again

What do the following commands return?

mmcli -L

systemctl status ModemManager

journalctl -b | grep ModemManager

1 Like

No modems were found



● ModemManager.service - Modem Manager
     Loaded: loaded (/usr/lib/systemd/system/ModemManager.service; enabled; vendor preset: disabled)
     Active: active (running) since Mon 2022-03-07 05:17:03 CET; 14h ago
   Main PID: 514 (ModemManager)
      Tasks: 3 (limit: 28666)
     Memory: 7.8M
        CPU: 45ms
     CGroup: /system.slice/ModemManager.service
             └─514 /usr/bin/ModemManager

Mär 07 05:17:03 saeki ModemManager[514]: <info>  ModemManager (version 1.18.6-1) starting in system >
Mär 07 05:17:03 saeki ModemManager[514]: [qrtr] socket lookup from 1:0
Mär 07 05:17:03 saeki ModemManager[514]: [qrtr] initial lookup finished
Mär 07 05:17:03 saeki systemd[1]: Started Modem Manager.
Mär 07 05:17:06 saeki ModemManager[514]: <info>  [base-manager] couldn't check support for device '/>
Mär 07 05:17:06 saeki ModemManager[514]: <info>  [base-manager] couldn't check support for device '/>
Mär 07 05:18:49 saeki systemd[1]: Started Modem Manager.
Mär 07 05:18:53 saeki systemd[1]: Started Modem Manager.
Mär 07 05:19:02 saeki systemd[1]: Started Modem Manager.
Mär 07 05:20:57 saeki systemd[1]: Started Modem Manager.
lines 1-20/20 (END)

Mär 07 05:17:03 saeki ModemManager[514]: <info>  ModemManager (version 1.18.6-1) starting in system bus...
Mär 07 05:17:03 saeki ModemManager[514]: [qrtr] socket lookup from 1:0
Mär 07 05:17:03 saeki ModemManager[514]: [qrtr] initial lookup finished
Mär 07 05:17:03 saeki audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=ModemManager comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Mär 07 05:17:04 saeki NetworkManager[492]: <info>  [1646626624.0889] modem-manager: ModemManager available
Mär 07 05:17:06 saeki ModemManager[514]: <info>  [base-manager] couldn't check support for device '/sys/devices/pci0000:00/0000:00:1c.0/0000:02:00.0': not supported by any plugin
Mär 07 05:17:06 saeki ModemManager[514]: <info>  [base-manager] couldn't check support for device '/sys/devices/pci0000:00/0000:00:1f.6': not supported by any plugin
Mär 07 05:18:45 saeki dbus-daemon[456]: [system] Activating via systemd: service name='org.freedesktop.home1' unit='dbus-org.freedesktop.home1.service' requested by ':1.44' (uid=0 pid=2849 comm="sudo systemctl enable --now ModemManager")
Mär 07 05:18:49 saeki sudo[2849]:    saeki : TTY=pts/0 ; PWD=/home/saeki ; USER=root ; COMMAND=/usr/bin/systemctl enable --now ModemManager
Mär 07 05:18:53 saeki dbus-daemon[456]: [system] Activating via systemd: service name='org.freedesktop.home1' unit='dbus-org.freedesktop.home1.service' requested by ':1.45' (uid=0 pid=2949 comm="sudo systemctl enable --now ModemManager")
Mär 07 05:18:53 saeki sudo[2949]:    saeki : TTY=pts/0 ; PWD=/home/saeki ; USER=root ; COMMAND=/usr/bin/systemctl enable --now ModemManager
Mär 07 05:19:02 saeki dbus-daemon[456]: [system] Activating via systemd: service name='org.freedesktop.home1' unit='dbus-org.freedesktop.home1.service' requested by ':1.46' (uid=0 pid=3108 comm="sudo systemctl enable --now ModemManager")
Mär 07 05:19:02 saeki sudo[3108]:    saeki : TTY=pts/0 ; PWD=/home/saeki ; USER=root ; COMMAND=/usr/bin/systemctl enable --now ModemManager
Mär 07 05:20:56 saeki dbus-daemon[456]: [system] Activating via systemd: service name='org.freedesktop.home1' unit='dbus-org.freedesktop.home1.service' requested by ':1.59' (uid=0 pid=3437 comm="sudo systemctl enable --now ModemManager")
Mär 07 05:20:56 saeki sudo[3437]:    saeki : TTY=pts/0 ; PWD=/home/saeki ; USER=root ; COMMAND=/usr/bin/systemctl enable --now ModemManager

1 Like

Your system is not finding the modem:

Since this modem works in the live installer environment, you shouldn’t have to whitelist it; this suggests to me that perhaps there is a kernel regression. Assuming you are using the current kernel (5.16.12), have you tried the LTS kernel?

i did right now, same problem sadly

Who makes the modem? Maybe this is related to the linux-firmware package split…

I do not know what this split is but
its a “Hutchison Drei” product

The linux-firmware package was split in January, with some firmware files being moved to other, new packages. This reduced the size of the linux-firmware package, but if you happen to need a driver that is no longer included, you will need to install that specific package. I don’t think that’s the issue here, but since the split occurred in January, and the EndeavourOS ISO is from December…I suppose it’s possible.

The fact that the modem works in the live environment suggests that something has changed since the ISO was created.

Let’s see what this command returns:

lsusb

I’m going to be away from the computer for a couple of hours, so I may not get back to you for a bit. Perhaps someone else will jump in in the meantime.

2 Likes

Did you install also usb_modeswitch?

Edit: I see there was an update tonight for usb_modeswitch on my system so it must be installed.

1 Like

I did recommended this during the early phase of conversation, but it wouldn’t worked.

Also, according to original author of topic, USB dongle is visible in file manager.
Then why not unmount it first, then use usb_modeswitch manually ?

1 Like

after the update it is working again, i will make this as the solution for now, i will come back to this if something happen to change in the future.
thank you all for the assistance.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.