LiveUSB Mobile broadband

Hello, this is my first question in a forum like this so excuse me if i dont provide the necessary information at first.

I had installed endeavouros before, for example i didnt have any problem with 2020.07, however i grabbed the latest 2020.09 version and it doesnt seem to recognize my mobile broadband internet stick.

Well, it does recognize it in the file manager but it does not recognize it when i try to connect to it for internet, it worked with the previous iso.

My question would be should i just start use the previous one and upgrade from there? if its better to use the current one with the updated packages? if so how would i be able to connect to mobile broadband?

1 Like

I’m pretty sure you could successfully update 2020.07, since that’s only two months, but it would be nice if the latest ISO fixed that problem.

Can you please try with the latest vanilla Arch ISO? Does it recognise your device? (just try pinging something like, because obviously, Arch ISO does not have a GUI).

Welcome to the forum, BTW.

1 Like

i have used linux for a long while now tho i never managed to get arch to a working state so im afraid trying it out with the arch iso isnt something im capable of doing.

But i will just use the previous iso and upgrade from there (like you have said) as it should just be a normal point release and im not knowledgeable enough to accurately find out what would be wrong with the current iso, tho it might take a little while longer because of it.

Thank you for your reply.

I think @Kresimir was just say … try and ping a web site via the arch iso … not install vanilla Arch

1 Like

I meant just boot the Arch ISO and run


and see whether you’ll have a network connection or not. Just to test whether the issue is upstream or something wrong with the latest EndeavourOS ISO. I’m not suggesting you install Arch.


Is ModemManager.service enabled?

systemctl status ModemManager


for Kresimir, ill see if i cant downlaod the arch iso later to see what it says, but for now

the outout is as follows:
Loaded: loaded (/usr/lib/systemd/system/ModemManager.service; disabled; vendor preset; disabled)
Active: inactive (dead)

1 Like

OK, you need to enable ModemManager.service.

But first, according to the Arch Wiki, you’ll want to make sure that you have the following packages installed:


Install any that may be missing.

Then enter the following in a terminal:

systemctl enable --now ModemManager

Plug in your modem and see if it works.

(The wiki notes that you might have to reboot. Personally I’d just go ahead and reboot before plugging in the modem anyway.)


well that is quite curious, i am as of now writing from the liveusb!
i used the " `systemctl enable --now ModemManager"

it did not show the modem in the option but it did connect to it after i set it up.

thank you very much for yours and the others help in this, im always pleasantly surprised to find a friendly forum!


If, after a reboot, the modem still doesn’t show up properly, check that the packages listed above are all installed.

In particular, usb_modeswitch may be needed to get the device showing up properly.


Hello :wave: @AmandaONeill, its cool to see other Austrians :austria: in the forum.
Welcome by the way and have a nice stay. :smile:

Welcome aboard!

thank you all for the kind wishes!

All 4 are installed, internet shows up without a problem as well, everything is working!

and a second thank you for the friendly forum!


I don’t know why it wouldn’t be? i just checked and it’s installed on my system.


I wasn’t sure if it was installed in Endeavour as default.

I don’t have it on my Arch installations, as I don’t need it.

1 Like

Well it’s on my KDE and i know this issue has come up before. I just wonder why the ModemManager doesn’t enable? Weird!

Edit: I don’t need it either but it’s on here?

1 Like

I imagine that the majority of users don’t use a mobile broadband USB modem, so the service isn’t active by default. That’s just a guess, mind you.

Those that do need the service can enable it.

It’s installed so that it’s ready to go, all that’s needed is to enable the service.