No Japanese Input in Proton Games

I use fcitx-mocz in order to type Japanese. I used to be using ibus-anthy and also had this issue. In a game, the input mode is always Romaji(Roman Characters) and I am unable to type Japanese Characters, Hiragana/Katakana/Kanji. It makes it hard for me to communicate with other players on the Japanese Servers on Final Fantasy XIV. It is not the only game, but the one where it is the most essential. fcitx is my preferred way, but if you have an other way of being able to do so, I am okay with switching to something else.

Edit: It works with wine games such as WOW and native games, the issue is only with proton games.

1 Like

Huh…I’m no expert here, but probably that would help others to debug:

  • What DE do you use?
  • Have you set Japanese as secondary language in your system?

I am using XFCE and I have it as my default input method. I have not added a secondary language to locale or anything like that. It works fine in my web browser or other software.

1 Like

Try before running game set this env variable, perhaps it could help (sometimes helped me in bi-lingual scenarios, not Japanese though since i don’t know it):

env LC_ALL=C 

I tried launching the game from a terminal after typing that, but I still can’t turn on mocz to type hiragana.

1 Like

I installed wow and surprisingly the Japanese input worked. I am running it with wine and dxvk, it also works in vulkan native games like dota. It seems like it is an issue only with proton.

1 Like

Huh…That’s weird, can you please then write a bug report about it on Proton bug tracker?

P.S. Glad to hear you’ve worked it out :wink:

Look, seems it’s universal for Proton, not only with FF

Exactly I have this issue with any proton games, my Japanese IME does not turn on. I press my keybind and nothing happens it keeps typing roman characters instead of allowing me to type Japanese characters like hiragana.

1 Like

Well, since they know it and it works with Wine i guess it’s only a matter of time then, meanwhile enjoy Wine :slight_smile: