No internet connection with no apparent reason

Hello! Today I started Endeavour and found that I have no internet connection over Ethernet and over wifi. The router works normally as I can use wi-fi on my phone with mobile network turned off. Last time I used my pc was on Thursday and everything was fine, I don’t remember tinkering with network in any way. What should I do to diagnose the problem? By far I tried switching to lts kernel but that got no effect.
Thanks!

Upd: ping google.com gives me “temporary error in name resolution”, while ping 8.8.8.8 gives PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.

Upd2: both pings work correctly with periodic ping result lines while endeavourOS live usb is booted, so I guess something went wrong with my installation.

Is it possible for you to give us your hardware and boot logs. Would be helpful in pointing us to the issue.

inxi -Fxxc0z --no-host 
journalctl -b -0

Just type these commands and paste the output in the forum.

Also if it is not too inconvenient, the easiest solution will be to reinstall as your internet is working on the liveiso

It seems that inxi is not installed as it gives me bash: inxi: command not found.
Here’s output for journalctl -b -0 from welcome tool

I would very much prefer not to reinstall system, as I’d spend too much time on reconfiguration.

This means it’s your DNS resolver settings.

Check your Network Manager settings, and the contents of /etc/resolv.conf.

Resolv.conf:
#Generated by NetworkManager
search Dlink
nameserver 192.168.1.0
nameserver fe80:c6e9:1aff:fe75:e8d4%wlan
nameserver fe80:c6e9:1aff:fe75:e8d4%enp1s0

As for network manager settings, I’m not sure what should I check and where. I could only find exact connections settings, not overall settings

That appears to be a broadcast address, so that’s unlikely to work. If this is being set by DHCP then your router’s configuration is wrong.

Depends on the DE, but you should be looking for something like this:

You can set the DNS resolvers manually and see if that helps (e.g. to 1.1.1.1 or 8.8.8.8 or 9.9.9.9 or another public DNS resolver).

1 Like

192.168.0.1 is my router’s admin page.

So connection settings should look like this?

Resolv.conf on live usb, which connects normaly, contains
nameserver 127.0.053
options edns0 trust-ad

After reboot with above-mentioned settings I got

Resolv.conf:
#Generated by NetworkManager
search Dlink
nameserver 8.8.8.8
nameserver fe80:c6e9:1aff:fe75:e8d4%enp1s0
nameserver 192.168.1.0
#NOTE: the libc resolver may not support more than 3 nameservers
#the nameservers listed below may not be recognized
nameserver fe80:c6e9:1aff:fe75:e8d4%wlan

You have added 8.8.8.8 to the available DNS resolvers - you can see it in the resolv.conf contents.

This means you have configured your installation to work differently. Only you know what you have changed.

Either your router is providing incorrect settings via DHCP or you have configured something incorrectly (e.g. a VPN).

I SUPPORT :ukraine:

Can you tell us the model of router, is it a Cisco or D-Link router? I see both in the logs.

In the meantime, make sure you have the setttings for the router, before you start anything. Is the router preconfigured by the ISP?

If you can ping the router 192.168.0.1? if so, then access your admin section of the router and try and export your router configuration first, then try doing a hard reset of your router, usually a button recessed under the casing. Check your router’s manual.

Here is my resolv.conf just for an example. It’s simple.

[michael@eos-22 etc]$ cat resolv.conf
#Generated by NetworkManager
search home
nameserver 192.168.1.1

FYI / FWIW ; )

Avoid polarizing content. We have a diverse member base spanning many geographies and cultures so please do not post content related to politics, religion or other controversial subjects.

https://forum.endeavouros.com/faq

:enos_flag::white_flag:

1 Like

Thanks, 8.8.8.8 is added to the list. There’s no difference as internet is not available still. I did configure two vpns, but both of them work through openconnect and you need to turn them on deliberately. Thanks for pointing on 192.168.0.1 va 192.168.1.0 inconsistency. That’s really strange.

It’s an ISP branded d-link, which is also preconfigured. 192.168.1.0 is not pingable for me. I’ll try resetting the router but I think it’s something with the OS, as my phone and live usb boot both seem to be working fine with the router.
P.S.: thanks for support.

Actually I’ve double checked nameserver is 192.168.0.1 which is correct address for router admin page.

How did you configure them? Did you make any changes to system configuration files?

If you pick a different option then you can set it to “Automatic (DHCP) addresses only” and make sure the working DNS resolver is the only one being used; otherwise the system will try to use non-working resolvers and fail.

I launch one of them in terminal by

sudo openconnect --server=*server address* --user=*user name*

Another is warp-cli and the last one is configured through network manager applet.

So the idea is that I should get rid of nameserver 192.168.1.0? I’m still not sure how do I do it.

Configure your connection to ignore the DHCP-provided DNS resolvers:

You can use one or more of those public DNS resolvers.

If the issue is being caused by Network Manager picking up the wrong DNS resolver then this will work around that problem. The next step would be to work out why you are being provided 192.168.1.0 in the first place.

2 Likes

What does your network show?

inxi -Na

Oh, right, forgot that I could put several resolvers. So i did. Resolv.conf now shows
search Dlink
nameserver 8.8.8.8
nameserver 1.1.1.1
nameserver 9 9.9 9
Note about 3 nameservers
nameserver 4.2.2.2
nameserver 192.168.0.1
nameserver fe80::c6e9:1aff:fe75:e8d4%wlan0
nameserver fe80::c6e9:1aff:fe75:e8d4%enp1s0

But there’s still no successful ping of google.com