No boot on 32bit UEFI with 64bit CPU

Hi. I tried to install endeavourOS, no desktop, on a cherry trail atom mini pc. I tried it before some time ago and it failed booting, identified cause as 32bit UEFI + 64bit CPU, which for some reason is not yet supported in endeavourOS. I fixed it last time by installing vanilla arch with the installer, which produced a bootable system.

Please tell me, step by step, what I must do, to get a bootable system. And if there’s a chance you will fix this in the installer eventually.

try to chroot in your system first.

is more or less

keep in mind luks btrfs depend what you have… have to read a bit

then try :

edit : the esp is /boot/efi when you chrooted… only mounted is /mnt/boot/efi

thought you need copy x32
but probably this can too

1 Like

To boot with 32bit UEFI you need 32bit boot loader (even with a 64bit CPU). EndeavourOS only ships with a 64bit boot loader.

To answer your last question, support for such a hardware combo isn’t on our roadmap since 32-bit UEFI in combination with a 64-bit CPU isn’t a widespread system configuration on most computers for some time now.

If you are able to run Arch on it and you want the EndeavourOS experience, you can also add our repo on it, that gives you the same experience.


you need a 32efi , there are stil such systems need 32bit efi, best see my arch wiki link

Why not ? It looks like a pretty simple thing to fix in the iso (arch fixed it). Why not support this even if there 0.01% users that have it ? Will still save a lot of users time and energy fixing/googling.

Because we are not a project that is funded by a big company, so we don’t have the manpower with the hardware to develop and test such systems.
Unless you want to develop it for us, you have the hardware and the insights to make this work. You’re welcome to come up with a solution. :wink:


You think I would have opened up this noob topic if I knew how to fix it for myself, let alone for the ISO ? :slight_smile:

I assumed you knew it, because you claimed it would be a minor and simple fix to add it to our ISO. My bad then…



Note: I only used the original for an ubuntu based iso (and it was a while ago), but the new should be universal and work on EndeavourOS as well.

Yeah just because it’s minor and simple doesn’t mean I know the inner workings and have the time to get involved in this, when it would take 10x less time for someone familiar with the system. I never built a linux iso in my life…

But it is really something that should be done. I just tried another very minor arch based distro, cachy os, and it booted without problems. So it is probably something they inherited from arch linux, I doubt they did anything special to make it work.
I will use that, as long as it’s arch based, it doesn’t really matter. Pure arch was too barebones with the config though, that’s why I wanted to avoid it.

Didn’t Arch fix it by completely replacing the bootloader? I am not sure this qualifies as a “pretty simple thing to fix”

Sounds like a good project. There’s still some out there that cater to the very old hardware!

Normally I am against using old hardware as servers as they use too much power… but these atom SOCs (which are the bulk of devices with 32bit uefi) only eat 5-6watts and are more powerful than a raspberry pi4, so it makes sense to use it as a small router/dhcp/dns/firewall etc.

Cool. Sounds like you’ve got what you need then. And there’s still a distro to help you with it.

Indeed, but for the betterment of endeavourOS, in hopes that one day it can replace manjaro for everyone, this should be fixed. It’s a bug, not a feature to have :slight_smile:

I tried that shell script in a vm and got this for the current endeavour ISO: ISO structure currently not supported. Exiting … ISO not created.

So I cannot test if the workaround works or not, to serve as base for a fix in endeavour.

There’s one very important thing you should know about 97% of the Linux distros out there, including us.
The majority of the distros out there are run by volunteers who have full-fletched jobs and a private life next to developing for the distro. So nobody is getting paid.
They also have to do that developing job with the hardware available, remember there is no steady and regular stream of money pumping into those distros. If that was the case, we would’ve had the money and the dedicated time to develop and fix every single flaw out there.

In our case, we are a team of six core developers and some community editions developers.
From the core team, three members are working on the x86-64 system, two of them are working on ARM and one is involved with the server, website, legal and finances.
All of them have full-time jobs and family/social life to attend to, next to this project which they do for the love of it.
To solve an issue for hardware like yours, means we have to find the time and money to hunt down and purchase hardware with those specs on top of the regular development, for example, making the distro work with mainstream hardware…

The easiest solution for this is for you to look into this because you already have the hardware and collaborate with us.
If you are not able to do that, we respect that but then don’t demand such a feature from us either, because we don’t have the hardware and the time to make it work.
Linux distros like this are working in a two-way street between the community and developers.
That’s the only way to go forward.


I understand. I thought it required hardware only for testing (info about the way to implement a fix is out there, and understandable for someone who is a distro dev). I am willing to test (if there is something to test).
The reply seemed dismissive like a “won’t fix” instead of, “ok we’ll add it to our long todo but no promises”.
Perhaps I misjudged endeavourOS as a kind of manjaro-ease-of-use/covenience, but with arch repos. It seems it does not want to be that… my bad.

EndeavourOS provides an easy install into Arch, from the first moment the system is installed it requires a hands on approach unlike Manjaro.

To be able to solve your issue means some of the team has to have that same hardware, since none of us have, we cannot work on it.