No audio after unplugging headphones

The audio worked fine, until i hooked it up to my external speakers via headphone jack. Worked fine through the external speakers as well. When going back to the regular speakers (laptop), it does not play any media audio.

The audio will work just fine if I replug in the external speakers, but when I disconnect I cannot hear anything. The irritating thing is that it is set to the correct setting (analog stereo duplex), and I can even hear the test output (front left, front right). But, that is the only audio I have.

I have tried reinstalling pipewire stuff (I see that I’m not the only one with issues), and it seems to be up and running. pactl info:

Server String: /run/user/1000/pulse/native
Library Protocol Version: 35
Server Protocol Version: 35
Is Local: yes
Client Index: 335
Tile Size: 65472
User Name: shawn
Host Name: shawn-latitudee5470
Server Name: PulseAudio (on PipeWire 0.3.77)
Server Version: 15.0.0
Default Sample Specification: float32le 2ch 48000Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_00_1f.3.analog-stereo
Default Source: alsa_input.pci-0000_00_1f.3.analog-stereo
Cookie: a807:5386

Any help is appreciated. I have not checked what is in the /run/user/1000/pulse/native, so I’ll putz around in there now.

EDIT: It is showing a blank document for the pulse/native thing with a no such device or address error, so I don’t know if it is really blank or just not showing me (the file is there).

This might be same problem as I was experiencing before.
Problem and solution (3rd reply) for it (downgrading to specific version) is outlined in

I tested newest pipewire versions today and that still had this same problem. I also noticed that this problem may manifest when changing audio sources, previously I only though this to be associated with hibernation.

Try restarting pipewire with

systemctl --user restart wireplumber pipewire pipewire-pulse

If that fixed it temporarily you can try downgrading pipewire and its dependencies, list of packages I needed to downgrade to fix this is listed in topic linked.

Thanks seeji,

Yes, I had seen and tried your post and solution. Didn’t work for this instance. I have since then tried switching away from pipewire and back, switching from wireplumber to whatever the deprecated package is (memory fails), and non of this works. =(

I’m using this laptop tonight, and we have a friend that needs to connect via discord. Thankfully someone else will be able to use their laptop to hear him, otherwise I would have already just reinstalled. I am sure there is some file somewhere that is messed up. It does seem that there are some issues to be ironed out with pipewire, although I get the impression it is an overall improvement. /=

So, FWIW, I haven’t done anything with this laptop except regular updates. I have noticed several pipewire / pulse updates, and the audio has gone back and forth from not working, to randomly working mid video / game / whatever, to right now working correctly. I assume it was / is a driver issue.

The laptop is a Dell Latitude E5470. Been very stable up till now. Just posting for clarity and reference.