New options for dracut

We have two different packages for dracut depending on which bootloader you choose during installation. Both packages, eos-dracut and kernel-install-for-dracut, have been updated with a new config file enabling a couple of options. The config file is located at /etc/eos-dracut.conf and /etc/kernel-install-for-dracut.conf respectively. Other than the name, the config files are identical.

There are currently two options in the config. The first enables dracut’s quiet mode to suppress most messages when building the initrd. The other option allows you to not generate a fallback initrd. Both options are disabled by default.

Instructions on how to set those values is contained in the conf file directly.


eos-dracut is not installed and everything is working?
Using Cassini ISO with systemd-boot - dracut.

$ cat /etc/eos-dracut.conf
cat: /etc/eos-dracut.conf: Arquivo ou diretório inexistente
$ yay -Ss eos-dracut
endeavouros/eos-dracut 1.1-1 (14.6 KiB 2.6 KiB)
    Dracut scripts and hooks for EndeavourOS

You should have either eos-dracut or kernel-install-for-dracut, not both.


Since you mentioned both in your OP, can you explain the differences between the two? Is there a preferred package?

eos-dracut is used with grub and kernel-install-for-dracut is used with systemd-boot.

You should already have one of them installed if you are using dracut. Just stick with that one.


At least with the Cassini.ISO kernel-install-for-dracut is preinstalled. There must be a reason for this.

Sorry, overlap with the posting of dalto.

already made the changes yesterday (according to github 30 minutes after you released the package :wink: ), works like a charm, thanks!


Which one for which bootloader? eos-dracut is for grub? kernel-install-for-dracut is for systemd-boot?


Setting DRACUT_QUIET="true" doesn’t seem to suppress the output for fallback image generation.

Which package and how did you test specifically?

I have the package kernel-install-for-dracut 1.7-2. I just edited the /etc/kernel-install-for-dracut.conf file to this:

# This config file controls the automation provided by kernel-install-for-dracut

# When DRACUT_QUIET is set to true, dracut will operate with quiet flag set suppressing most output

# When NO_FALLBACK is set to true, no fallback initrd will be generated

and then ran sudo reinstall-kernels.

Hmm…it works here.

What is output of ls /etc/kernel/install.d ?


You shouldn’t have this one. Did you override the fallback generation at some point? Try rm’ing that one.

1 Like

I think I added that while trying to make dracut quiet here. It was your suggestion, it looks like haha.
Anyway, removing that seems to work!

1 Like

Yeah, you probably added that file to override the behaviour. However, it also overrode my changes to support quiet. :wink:

However, there has been no talk of this so far. Only what is written in the config files as instructions. :thinking:

That is how he was testing to see if it worked. It isn’t required.

I have kernel instal both from AUR and EndeavourOs, see below

[henry@henry-81n3 ~]$ cat kernel-install-for-dracut
**strong text**cat: kernel-install-for-dracut: No such file or directory**strong text**
[henry@henry-81n3 ~]$ yay kernel-install-for-dracut
2 aur/kernel-install-for-dracut 1.7-1 (+2 0.12) (Installed: 1.7-2)
    Enables systemd-boot automation using kernel-install with dracut
1 endeavouros/kernel-install-for-dracut 1.7-2 (18.0 KiB 19.3 KiB) (Installed)
    Enables systemd-boot automation using kernel-install with dracut
==> Packages to install (eg: 1 2 3, 1-3 or ^4)
 there is nothing to do

How can I resolve this?