New Installation EOS, installion Libreoffice-fresh about welcome

When I start LO after installing it through welcome, the icon appears in the taskbar. There is brief tiny graphical information above it. (Appendix) That’s all. No window opens for Writer.
When I try to start LO in the console, the result is: command not found.
Yesterday I installed EOS and LO on another PC, and it worked.
it is very strange. I would be very happy about help
screenshot LO

After a restart the console command works, but there is no window for LO

libre-office-fresh or still?
And do you add it to the panel or does it appear on its own?

Screenshot_20220921_122558
libre-office-fresh on plasma

so it is not a general issue…

You are running plasma on wayland?
What shows it as installed:
yay -Qs office

  1. yes
  2. on its own

grafik
2.
~]$ yay -Qs office
local/libcdr 0.1.7-4

CorelDraw file format importer library for LibreOffice

local/libreoffice-fresh 7.4.1-2

LibreOffice branch which contains new features and program enhancements

local/libreoffice-fresh-de 7.4.1-1

German language pack for LibreOffice Fresh

local/libstaroffice 0.0.7-2

filter for old StarOffice documents(.sdc, .sdw, ...) based on librevenge

Try this advice from Archwiki.

Check this first:

echo $SAL_USE_VCLPLUGIN

It gives an empty output.

But this command from ArchWiki was helpfull

LD_PRELOAD=/usr/lib/libfreetype.so libreoffice
javaldx: Could not find a Java Runtime Environment! Warning: failed to read path from javaldx

LO started in the console, and after closing it, not from starter

Should I install this?

aket (4)                   Neue Version   Netto-Veränderung  Größe des Downloads

extra/java-runtime-common   3-3                     0,01 MiB             0,00 MiB
extra/jre-openjdk-headless  18.0.2.1.u0-1         168,35 MiB            37,16 MiB
extra/libnet                1:1.1.6-1               0,30 MiB             0,09 MiB
extra/jre-openjdk           18.0.2.1.u0-1           0,49 MiB             0,18 MiB

Gesamtgröße des Downloads:              37,44 MiB
Gesamtgröße der installierten Pakete:  169,15 MiB

My install/update action above did not help. LO does not start either with
LD_PRELOAD=/usr/lib/libfreetype.so libreoffice

Installiere bitte das dt. Sprachpaket nach:
yay -S libreoffice-fresh-i18n
Danach sollte es eigentlich gehen, lt. Doku im ArchWiki:

  • In the past, the installation of at least 1 language pack was required. Currently, LibreOffice detects your system defaults and sets as locale setting; manual installation of a language pack is no longer mandatory, required only for localized user interface. See help.libreoffice.org for additional information.

Und auch:

Check the optional dependencies pacman displays. If you use HSQLDB Embedded in LibreOffice Base, you must install a Java Runtime Environment. You may need hsqldb2-javaAUR to use some modules in LibreOffice Base.

Last, not least:

Troubleshooting

A general way to track down problems is the safe mode in LibreOffice:

$ libreoffice --safe-mode

It is optional. Not related to your issue.

Then do as wiki says to enable and set this to gtk3

I can confirm i get the same when logging in under Wayland in plasma. I am also unable to load an image in the post as Firefox crashes.

Perhaps a way:
I did erase ~/.config/libreoffice
but you must do that every time

Check the output from terminal, when running the command with user-config in place.

1 Like
[ricklinux@kde-pc ~]$ libreoffice --safe-mode
javaldx: Could not find a Java Runtime Environment!
Warning: failed to read path from javaldx
qt.qpa.wayland: Wayland does not support QWindow::requestActivate()
qt.qpa.wayland: Wayland does not support QWindow::requestActivate()
qt.qpa.wayland: Wayland does not support QWindow::requestActivate()
[ricklinux@kde-pc ~]$ 

Libreoffice does open

Edit: I tried earlier to set this but didn’t help. Firefox still crashed.

MOZ_ENABLE_WAYLAND=1

:point_up:

This is why i don’t bother with Wayland.

1 Like

Understandable. It simply doesn’t play well with many hardware environments. When using it, be prepared for system-freezes and -breakdowns:
Alphaville

2 Likes

Can you check this as well?

I already removed plasma-wayland-session. :grin: