New install, bluetooth won't work

Hello everyone. I’ve been trying multiple different distros and have settled on Endeavour for now. However, on all of them I’ve tried, I can’t get bluetooth to work properly. It says that its enabled, but when I search for my xbox controller or my keyboard, it doesn’t find any devices. Just sits there and says searching.

I ran inxi -FAZ --no-host | eos-sendlog and here is the link that it gave me:

https://0x0.st/Hnl3.txt

rfkill list gives me:

0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

Is there any other info that you guys need to help diagnose this? I am fairly new to Linux too. Thank you!

After installation, did you run:

sudo systemctl enable --now bluetooth.service

?

Yes I did. It’s running and seems to be working. But doesn’t find any devices to pair with. Works fine in Windows. And this happened over every distro and every kernel that I’ve tried.

Can you try bluetoothctl from the terminal and see if it will work?

https://wiki.archlinux.org/title/Bluetooth#Pairing

1 Like

It does the same thing. It says it’s working and when I run “scan on” it says it’s searching and pairable, but never finds any devices.

1 Like

@hahler2
Have you gone through all the steps with bluetooth ctl?

https://discovery.endeavouros.com/audio/bluetooth/2021/03/

Yes, I have gone through all those steps.

Okay then I would suggest booting into Windows and under power management disable the fast startup feature in Windows. Then I would shutdown and unplug the tower. Press and hold down the power button for 30 seconds. Plug back in and start up the computer and see if that makes any difference.

3 Likes

I’m pretty sure I have fast startup disabled all ready, but I will check that and give it a try! I will let you know how that goes.

Is it a usb device for bluetooth?

No it’s integrated in the motherboard.

Also, that fixed it! I have recently done a fresh install of Windows 11 and had forgotten to disable fast startup. Thank you!!!

I thought it was integrated and this is usually the problem. Glad it’s working.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.