Network not detecting wired ethernet

I’m trying to turn on wired ethernet, and gnome settings network tab isn’t showing the wired ethernet.

I ran inxi -Na and this is what is see:

Network:
  Device-1: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: N/A
    modules: r8169 pcie: gen: 2 speed: 5 GT/s lanes: 1 port: f000
    bus-ID: 26:00.0 chip-ID: 10ec:8125 class-ID: 0200
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 28:00.0 chip-ID: 8086:2723 class-ID: 0280

it seems that r8169 driver wasn’t loaded properly and i tried running:

modprobe -r r8168
modprobe r8169
systemctl restart NetworkManager

and the wired ethernet shows up in gnome settings and after a few seconds of acquiring ip, i have internet access. but after i reboot my pc, i have to restart the entire process. is there any way to make modprobe persistent?

Maybe the module is blacklisted? See if there is an entry of r8186 in /etc/modprobe.d/ or /usr/lib/modprobe.d/

Check your journal with sudo journalctl -b | grep r8168
maybe you’ll find more info there.

If r8169 is the module working, you could just uninstall r8168.

Or blacklist r8168.

Please have a look here:

after running cat /usr/lib/modprobe.d/r8168.conf, i see blacklist r8169. should i remove this line?

I’ve updated /usr/lib/modprobe.d/r8168.conf to blacklist r8168 instead. and it restarting uses the right driver now. thanks.

1 Like

You are not done yet.
This file is provided by a package, normally. Check the owner, so you know. It will be reverted with the owner package update.

To make the change proper, copy that file at /etc/modprobe.d/ . This is the relevant path for overriding package configs.

1 Like

Good point!
The Wiki article needs some rewriting then I guess.

1 Like

ls -al /usr/lib/modprobe.d/ prints this.

I’ve copied over to /etc/modprobe.d/ as suggested. Hopefully the setting remains after update. Thanks.

1 Like

In order to check what package owns a certain file, you can use:

pacman -Qo /path/to/file

In this case:

pacman -Qo /usr/lib/modprobe.d/r8168.conf

/usr/lib/modprobe.d/r8168.conf is owned by r8168 8.050.03-9

thanks.

1 Like

To clear misunderstandings, I talked about ONE file, that is creating the problem and needs to be overridden, not every file.

I just simplified the r8168 instructions: see

Hopefully it is more clear now. :smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.