Network Controller Issue

I have an hp620 with ralink rt3090bc4.
Following the arch linux guide to setup network I runned the lspci and lspci -k commands and both showed Ethernet Controller but not Network Controller, so I runned rfkill list and it only showed bluetooth; thinking it was a driver problem I went under module-load.b created the file program.conf and added rt2800pci(a driver compatible with rt3090), then I restarted the pc.
Runned lsmod and now I could see rt2800pci(before it was not present) but the outcome of the above commands didn’t change.
I am new to linux, I’b be glad if any of you could help, thanks.
Edit: Forgot to mention that iw dev returned nothing and ip link returned the loopback(lo) and ens5 which to my understanding should be Ethernet

I think you mean it shows the Ethernet controller but not WiFi.

Are you able to run

inxi -Na

Yeah essentially, I need wifi.

The command returned

  Device-1: Realtek RTL810xE PCI Express Fast Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 84:00.0 chip-ID: 10ec:8136
    class-ID: 0200

So it’s not even showing the WiFi after you created the program.conf


I would remove that file and try something different. That chip is very problematic. Most ralink are.

Ok thanks, what should I try?

Give me a minute.

Try the following

sudo modprobe -r rt2800pci
sudo modprobe rt2800pci

I just removed the file should I restart the pc before trying this commands?

Sure why not it won’t hurt.

1 Like

I also wanted to ask for you to make sure the WiFi is actually turned on? I don’t know what F keys it is but you should double check that.

Edit: Until we get it to recognize and list the hardware it’s not going to work.

You mean the physical key?

Yes… the key that turns WiFi on and off.

I tried to run all the previosly mentioned command with the key on and off, and the only difference that in rfkill list bluetooth was hard blocked

Just make sure WiFi is on.

I runned these command then tried inxi -Na and other command but the outcome was the same

Have you tried the lts kernel?

You can install the package akm that is a kernel manager. It makes it easy to install another kernel.

No. Is there a guide I can follow?

Just install akm

sudo pacman -S akm

Then install the lts kernel. It will automatically install the headers required.


Then reboot into lts kernel and see if it recognizes the wifi chip.

Edit2: akm should be in the menu somewhere once you install it. Not sure what desktop you are using.