Neofetch - bash issue

Hi All
I am a self-taught Linux user for 10 years.
My problem at the moment is I have this line at top of my terminal panel : .config/neofetch/config.conf: line 1: $’\357\273\277#’: command not found
I have never encountered it before and do not know the solution.It affects nothing but very annoying.
When I remove neofetch entry from my .bashrc file it`s gone .

Please help???

Go into the mentioned file (.config/neofetch/config.conf) and remove the first line. Do make a backup of that file before changing it.

1 Like

First, welcome to :enos: forums.

That’s really strange because normally line one and two of the mentioned config file is similar to below.

# See this wiki page for more info:
# https://github.com/dylanaraps/neofetch/wiki/Customizing-Info

Unless you edited the file and add some text or command.

1 Like

This looks like an issue with utf-8. The sequence \357\273\277 is a UTF-8 byte order mark.

There are several ways how to remove the mark:

Also helpful might be:

1 Like

does not solve

exactly the same lines as mine . Thanks

Welcome to the forum @solarguy :tada::balloon::partying_face:

Okay I had a similar issue a month or two ago. Not sure if I had posted about it, but for myself the solution was simple. Note, this only applies to the Tilix terminal, so if you use Gnome Terminal, or Konsole, etc, the option may or may not be there.

I’ll explain it through Tilix, hopefully your terminal of choice has similar options.

  • Go to you terminal preferences
  • Under Profiles, you have various options to customize colors, spacing, sounds, etc
  • Under the Command heading, make sure “Run command as login shell” is NOT CHECKED
  • Close the preferences and close your terminal and restart it.
  • You should hopefully now be good to go!

I’m posting this now, but in a moment I’ll install Gnome Terminal and see if it has similar options as well in case that’s the terminal you’re using.
Let us know if this works!

Screenshot from 2021-11-11 12-50-26

Edit: Here’s the post I was thinking of:

I’ve tried turning the “Run command as a login shell” on and off, but I haven’t noticed a difference, so it’s possible that my solution may not work for you since I don’t think the issues are the same, but it’s worth a try nonetheless.

This solved my problem: ```
dos2unix file.txt
Thank you so much.Awesome support

1 Like