Nemo and Firefox take ~1 min to launch

Hello. As the title suggests the file browser Nemo and firefox takes a while to load. This is an issue that only occurs when I am on i3 for some unknown reason. As far as I can tell this only applies to these two programs and only on i3. When I’m on a DE this does not happen. If this isn’t the right place to post this question, please point me to the right place and I’ll post it again there. Thanks.

Please ensure you don’t have xdg-desktop-portal-gnome installed. If you do, replace it with xdg-desktop-portal-gtk

1 Like

Hello. I tried your suggestion and did a restart and the results are still the same. If it matters my DE is Cinnamon.

Can you share the output of pacman -Q | grep portal

Of course. Here it is.

libportal 0.6-1
libportal-gtk3 0.6-1
xdg-desktop-portal 1.16.0-3
xdg-desktop-portal-gtk 1.14.1-1
xdg-desktop-portal-xapp 1.0.1-1

Hi @dalto are there any updates?

is what was to identify… you do not have this installed–

filesystem has space left?

Yes it does.

As for checking whether either was installed I have portal-gtk installed and portal-gnome is also not on my system.

hi @joekamprad I provided the information, could you take a look at it?

@joekamprad @dalto Are the both of you available to help me out? I’d really like to get this solved. I apologize if I’m unable to respond quickly as it is way past my bedtime try to solve other related issues.

Unfortunately, there is no immediate answer. It needs investigation by yourself, because it doesn’t happen for every other user. Some configuration on your system may create this issue.

It could also be a kernel related problem. I also had FF starting with such a delay. Today it doesn’t happen :person_shrugging: .

  • Test other kernels.
  • Check journal for error messages
  • Start the programs in terminal and if it also lags, post terminal output
  • Check upstream development for similar bug reports (firefox, nemo, i3)
  • Create a new user account and try to reproduce it.

The more info you provide, the sooner we can find a solution or workaround :person_shrugging:


you can send me a full boot journal for me to check if i can get any hint on issues:
journalctl -k -b -0 | eos-sendlog but do not post the pastebin url here and instead send it to me in PM it can include urls and private stuff you do not want to share public… you can also write it to file and check yourself:

journalctl -k -b -0 > ~/bootlog.txt

this also indicates you may have more Desktops installed? or only i3 and cinnamon?

I have been trying but I wasn’t sure exactly what to look for.

I had no idea what to look for thanks for giving me this :pray:

1 Like

Not … do not send Journal in public please… you can send me in a private Message but not here …

Jun 29 07:04:49 machine kernel: VGA switcheroo: detected Optimus DSM method _SB_.PCI0.PEG0.PEGP handle

can you show:
inxi -Gaz
lspci -vnn | grep '\''[030[02]\]'

Yeah no problem here’s output for inxi -Gaz

  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Dell driver: i915
    v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
    active: eDP-1 empty: DP-1, DP-2, HDMI-A-2, HDMI-A-3 bus-ID: 00:02.0
    chip-ID: 8086:9bc4 class-ID: 0300
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: Dell
    driver: nouveau v: kernel non-free: 530.xx+ status: current (as of 2023-05)
    arch: Turing code: TUxxx process: TSMC 12nm FF built: 2018-22 pcie: gen: 3
    speed: 8 GT/s lanes: 8 link-max: lanes: 16 ports: active: HDMI-A-1
    empty: none bus-ID: 01:00.0 chip-ID: 10de:1f95 class-ID: 0300 temp: 51.0 C
  Device-3: Microdia Dual Mode Camera (8006 VGA) driver: hid-generic,usbhid
    type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-2:3
    chip-ID: 0c45:8006 class-ID: 0301
  Device-4: Sunplus Innovation Integrated_Webcam_HD driver: uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:4
    chip-ID: 1bcf:2b99 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.8 driver: X: loaded: modesetting
    alternate: fbdev,intel,nouveau,nv,vesa dri: iris,nouveau gpu: i915,nouveau
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.88x11.22")
    s-diag: 1052mm (41.43")
  Monitor-1: HDMI-A-1 mapped: HDMI-1-1 pos: primary,right model: Acer SA271
    serial: <filter> built: 2022 res: 1920x1080 hz: 75 dpi: 82 gamma: 1.2
    size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  Monitor-2: eDP-1 pos: left model: BOE Display 0x092a built: 2020
    res: 1920x1080 hz: 120 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
  API: OpenGL v: 4.6 Mesa 23.1.3 renderer: Mesa Intel UHD Graphics (CML GT2)
    direct-render: Yes

As for the other command there seems to be an error I tried to fix it to lspci -vnn | grep '\''[030[02]\] but it yielded no output.

missing the last '
lspci -vnn | grep '\''[030[02]\]'

shows you are running optimus system for sure… it renders only over the igpu (intel) and do not use the Nvidia dGPU…

This can make system laggy in cases …