Need help to automount internal drives & get apps to read/write to them

Hello folks! I’m something of a veteran newbie (I’ve been dipping my toes on the Linux lake for quite a while, but never got to actually learn the ins and outs).
Recently I decided to go full Linux after some months running Mint on my spare laptop. But since I wanted to DIVE INTO IT, I did some research (half an hour reading about some distros) and decided to go EndeavourOS, it being Arch but kind of user friendly.
I’m dual booting W10 and Endeavour (I’m keeping W10 to deal with those pesky macro keyboard apps I couldn’t get to work through wine). The drives I have:

  • 500GB SSD for both systems (180GB for W10, the resto for EOS)
  • 250 SATA SSD (exFAT)
  • 1TB SSD (exFAT)
  • 2TB HDD (Ext4)
  • 4TB HDD (exFAT)

The reason for the exFAT ones is simple: I hoard data, so I used the (then) brand new 4TB one to maneuver all my files and libraries around, then got the 1TB to exFAT (since apparently that’s the to go format if I wanted them for both Windows and Linux), and decided to format the 2TB one exclusively for Linux.
I decided to configure qBittorrent to place my downloads on the 2TB HDD, but through the preferences menu I just couldn’t get out of the EOS partition. I decided to copy the directory path and paste it there, and it seemed to work… Until my next reboot.
Suddenly, qBittorrent couldn’t write to the drive. I went online, messed around a bit, installed the Gnome Disk utility, tried “taking ownership” and automounting the drive, nothing. Then I went back to Windows, disabled hibernation and auto startup (that’s what I’ve seen folk saying could solve this), rebooted, tried taking ownership and automounting again, rebooted… nothing.
Now I’m worried about any other “external library” not contained on the OS partition. I probably won’t be able to create a Steam library there, nor anything else. Every other topic here on this forum I looked at seemed to be about people trying to automount NTFS partitions, and that’s not my case.
Here’s how it’s set:

And I get really confused about that “identify as” part… people say I shouldn’t change that for REASONS, though I also wanted to know if I could change it to something resembling human language on the drop-down menu (which for some reason I’m unable to take a screenshot of).
Almost forgot to show the main view of the device

I’m really willing to learn, but hell, this should be simple, right? Maybe I’m just stupid or something :sweat_smile:
EDIT: Don’t know if it helps, but here’s the config I’m trying to use on qBittorrent

The simple answer is to set up fstab to mount your internal drives as you wish. Some choose to mount them to /mnt/$PARTITION some will do /home/$PARTITION to do so with fstab you will need to get the UUID of the partitions to mount and setup fstab like so

UUID=1234567890987654321 /mnt/DATA-01 /ext4 defaults,noatime 0 0

the above would be an example of how to put it into fstab.

the UUID points to the partition you wish to mount
/mnt/DATA-01 is the mount point
/ext4 this is the file system that the partition is using
defaults,noatime,nofail are mount options

with ntfs and exfat I think you need some other options like nofail however since I don’t use either of those i can’t give more info on that.

1 Like

Well… I have no clue what’s fstab :sweat_smile: :sweat_smile:

Though thanks for pointing me in the right direction! I’ll do some reading on it! :smiley:

For example try terminal command

man fstab

The actual file is /etc/fstab where you’d write the mount definitions.


Reading the manual made understand it even less. What should I actually do? Edit the fstab file? Run commands? I’m REALLY dumb and I’m feeling like having a hart attack right now. I don’t truly understand the concepts of mounting points (apparently), I have no idea what to do. THis is what my fstab shows

I made a backup copy, tried copying the options for the previous partitions, rebooted some 10 times changing the values, and so far I got a headache and probably a trip to the doctor.

Have no worries mate!

You simply edit that file e.g. with command

sudo nano /etc/fstsb

Sudo gives you the required privileges to edit this file.
Nano is a relatively easy to use editor.

Each partition you want to mount needs a line in the file.
Look at the existing lines how they are constructed.

But before editing you need some info about the partitions, e.g. command

lsblk -fm

Then the mount point: it is a directory where a partition will be attached.
You create a directory for each partition, e.g.

sudo mkdir -p /mounts/p1

You can pick the directory names quite freely.

Now you use this info when editing the file. Use the correct UUIDs from lsblk and the created mount points.
And read man fstab again about the parameters.

But now I have to go, hopefully others can help further if needed. Will be back tomorrow.


My advice is: get rid of windoze garbage and exFAT. You will have much less headache in the future.

exFAT is not a POSIX compatible filesystem. Linux was meant to run on a POSIX compatible filesystem, because permissions and file ownership are essential to security. If you move files back and forth between an exFAT drive and a ext4 drive, you will lose metadata, and because of bad file permissions, you will encounter strange bugs and errors that are notoriously difficult to troubleshoot.

Linux loses all benefits of being a secure operating system if you have malware like windoze installed on the same computer. Windoze (as well as other micro$oft and third-party malware running on windoze) can access your Linux drives (including ext4) and modify them without your knowledge or consent – file permissions mean nothing to windoze.

Dual booting is much more prone to errors than keeping a single OS, and the system maintenance is much more complicated. It is also psychologically bad, because it demotivates the user to leave their comfort zone: every time you don’t know how to do something on Linux (which for a newbie is all the time), instead of being forced to learn it, you will be tempted to do it on windoze. Just this onceTM. It’s like an alcoholic trying to quit drinking, but keeping a cabinet full of booze at home.

By creating this dual boot abomination, you are sacrificing so much, and for what? Some stupid keyboard macro program…

Of course, it’s your system, you’re free to do what you want.

@manuel @thefrog @eznix JUst a n update for you guys.

Somehow I made it work, leaving everything as it was, but adding a rw option to the mount.

Later on the week I’ll try and make it tidy like you guys showed.

But I got an unexpected side effect and I could use some more help (just for tidiness): I ended up with lots of folders (the mounting points, I’m still trying to wrap my head around the proper nomenclature), which I don’t seem to be able to delete. They’re just there, empty, and I know this could confuse me on the long run. Is there a “countercommand” to mkdir ? Or some obvious way my non-linux mind is blatantly ignoring?

And thankls again for being patient and trying to help me out :smiley:

1 Like

you need to take ownership of the folders in order to delete them.

chown -R $USERNAME:$USERGROUP /mnt/Path-to-delete

then you should be able to delete it.

rm -rf /mnt/Path-to-delete

1 Like

Awesome! Now things are starting to make more sense to me (I think haha).

ANd just to be absolutely sure: Can i mount a partition to my home folder? like /home/user/mountpoint ? Because from what I understand, the mounting point will be like a “link” folder to the relevant partition, right? I’m sorry if I’m still thinking in windoe terms :sweat_smile:

yes you can its how I mount my two extra internal drives.

1 Like

Weird thing happened… i tried the chown command, but the operation is not permitted. But then I used sudo in front of it and it worked like magic :rofl:

sudo= :magic_wand: when required. :wink:

1 Like

Well, since I can only mark one reply as the solution, I wanted to thank both @manuel and @thefrog for helping me out. Using the advice both of you gave me solved my issues.

As for the guy who when on a rant without actually trying to give a modicum of advice, well… you’re part of the reason why newbies usually don’t migrate to Linux. Either be more thoughtful or just don’t bother to open your mouth (or type).

A great post and some very helpful replies. I’ve moved the Home directory previously but only on a single drive, there’s some good tips here for taking that further over multiple drives. I’ve used the fstab edit to mount a NAS box as well so it’s a handy thing to know.

I found this article useful, hopefully you find something in it also…

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.