Mysterious issues with fresh install

Hello! I’m new to Linux but have been interested in moving to it from Windows for some time. Recently I installed EndeavourOS because I have a friend who uses and recommends Arch, I like trying to solve issues on my own and the repository of knowledge for Arch is extensive, and because it’s purple. :purple_heart:

However, I’ve been having a rough time getting started with using my new operating system and running into a number of issues ranging from minor but solved by patience to my whole computer coming to a screeching halt. Discussions with my more tech-savvy friend have not left me with many answers, so I’m hoping to find some solutions here to improve my experience with Linux :smiley:

To start, here is the printout of my specifications from inxi -Fxz --no-host, which I’ve seen a number of other posts provide:

Kernel: 6.9.1-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
Desktop: KDE Plasma v: 6.0.4 Distro: EndeavourOS base: Arch Linux
Type: Laptop System: ASUSTeK product: ROG Zephyrus M16 GU603ZM_GU603ZM
v: 1.0 serial:
Mobo: ASUSTeK model: GU603ZM v: 1.0 serial:
UEFI: American Megatrends LLC. v: GU603ZM.311 date: 12/22/2022
ID-1: BAT0 charge: 54.4 Wh (62.0%) condition: 87.7/90.0 Wh (97.5%)
volts: 15.9 min: 15.9 model: ASUSTeK ASUS Battery status: not charging
Info: 14-core (6-mt/8-st) model: 12th Gen Intel Core i7-12700H bits: 64
type: MST AMCP arch: Alder Lake rev: 3 cache: L1: 1.2 MiB L2: 11.5 MiB
L3: 24 MiB
Speed (MHz): avg: 451 high: 716 min/max: 400/4600:4700:3500 cores: 1: 400
2: 582 3: 400 4: 400 5: 716 6: 400 7: 654 8: 467 9: 571 10: 400 11: 400
12: 434 13: 400 14: 400 15: 400 16: 400 17: 400 18: 400 19: 400 20: 400
bogomips: 107560
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Device-1: Intel Alder Lake-P GT2 [Iris Xe Graphics] vendor: ASUSTeK
driver: i915 v: kernel arch: Gen-12.2 bus-ID: 00:02.0
Device-2: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: ASUSTeK
driver: nvidia v: 550.78 arch: Ampere bus-ID: 01:00.0
Device-3: Quanta USB2.0 HD UVC WebCam driver: uvcvideo type: USB
bus-ID: 3-8:4
Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0 driver: X:
loaded: modesetting,nvidia dri: iris gpu: i915 resolution: 1920x1200~165Hz
API: EGL v: 1.5 drivers: iris,nvidia,swrast platforms:
active: gbm,x11,surfaceless,device inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.0.7-arch1.3
glx-v: 1.4 direct-render: yes renderer: Mesa Intel Graphics (ADL GT2)
API: Vulkan v: 1.3.279 drivers: nvidia surfaces: xcb,xlib devices: 1
Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
Device-2: NVIDIA GA106 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus-ID: 01:00.1
API: ALSA v: k6.9.1-arch1-1 status: kernel-api
Server-1: PipeWire v: 1.0.6 status: active
Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3
IF: wlan0 state: up mac:
Device-2: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
port: 3000 bus-ID: 2e:00.0
IF: eno2 state: down mac:
Device-1: Intel AX211 Bluetooth driver: btusb v: 0.8 type: USB
bus-ID: 3-10:6
Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: disabled
rfk-block: hardware: no software: no address: N/A
Local Storage: total: 3.64 TiB used: 16.83 GiB (0.5%)
ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 980 PRO 2TB size: 1.82 TiB
temp: 25.9 C
ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 980 PRO 2TB size: 1.82 TiB
temp: 26.9 C
ID-1: / size: 1.77 TiB used: 16.56 GiB (0.9%) fs: ext4 dev: /dev/nvme0n1p2
ID-1: swap-1 type: partition size: 16.85 GiB used: 0 KiB (0.0%)
dev: /dev/nvme0n1p3
System Temperatures: cpu: 27.0 C mobo: N/A
Fan Speeds (rpm): N/A
Memory: total: 16 GiB note: est. available: 15.31 GiB used: 4.12 GiB (26.9%)
Processes: 366 Uptime: 14m Init: systemd
Packages: 1205 Compilers: gcc: 14.1.1 Shell: Bash v: 5.2.26 inxi: 3.3.34

I also have SysRq Key enabled which generally allows me to escape total halts with REISUB, but this is about where most of my experience ends.

I have also tried fresh installs with Cinnamon and Xfce, both of which didn’t make much of a difference so I went back to KDE because it looks nicest to me.

Another potentially important factor is that I do have a Windows 11 installation on the second drive in my device, which I use as a backup in the event Endeavour is giving me too many issues and I need a break or something isn’t working when I need it to. I’m hoping to get rid of this installation someday but for now it’s just there in case.

As for the issues;

  • When shutting down or rebooting, my laptop halts on a black screen after all of the shutdown text clears for roughly 90s or longer, but the startup time after the BIOS splash is as quick as if was using just Windows. (I use systemd-boot, for what it’s worth)
  • Occasionally upon starting the device, the keyboard and mouse do not work for some time and may require unplugging the latter before the former works so I can log in.
  • Once logged in, the Welcome window that comes with Endeavour takes roughly 2m 30s to 3m to open. This occurs regardless of if it’s the instance that automatically opens on startup or if I start it manually later. Additional applications that have a similarly sluggish start time are Steam and ATLauncher.
  • Using Lutris and Wine, the FFXIV Dawntrail Benchmark tool will frequently completely freeze my computer after launching, but is inconsistent in doing so. Sometimes I can launch it up to four times in a row with no issues through to the end, and others it will launch to a black screen and either load forever with or without music or stay on a totally black screen.

I know I have seen a lot of posts about issues with steam and other applications loading slowly, and those generally have said to remove xdg-desktop-portal-gnome on a non-GNOME DE, but this doesn’t work for me because that package is not installed. Installing it has also not solved the issue.

These are most of what I can remember at the current time, and definitely the most problematic ones. I think there might have been something related to playing a game with a friend but being unable to connect to them or having some issues with the UI, but it has been a while since I’ve tried something like that.

I appreciate any help anyone can offer! I hope I’m not asking about super common question that I somehow skimmed over in the existing forums or wiki pages :x

Welcome to the community! :enos_flag: :vulcan_salute:

Try this:

sudo pacman -S linux-lts linux-lts-headers

Then reboot.

Here’s a link to EndeavousOS’s wiki on this:

1 Like

Hi! Thank you for the quick reply! I tried the commands you provided and rebooted my system, but sadly not much appears to be changed.

The reboot still took well over a minute to even shut down, once my laptop had started again the keyboard and mouse still were not responsive until I unplugged and plugged the mouse back in, and the EndeavourOS Welcome window and Steam still took roughly two minutes to open. ;w;

When reached the systemd boot menu though, there was a new lts option! I made sure to select that when starting (which I think is what I was meant to do.)

1 Like

Correct. Good.

Only other thing I can think of is maybe it’s firmware related…

What would @dalto do?

1 Like

G’day @Malva! :wave::sunglasses:

Just to clarify, the keyboard that is unresponsive is the laptop’s built-in keyboard? (it’s not one also connected via USB?)

1 Like

Good day! :smiley:

Yes, it is! Sorry, I should have clarified that :x

The keyboard is on the laptop itself, and the mouse is a wireless Corsair mouse connected via a dongle. It is not part of a mouse and keyboard set like some wireless devices might.

1 Like

you have an nvidia try installing the nvidia-lts package to go with the lts kernel. Unfortuantely my Nvidia system is down ATM.

1 Like

I’m responding to a “Dev ISO tester” here, so I really feel out of my league, so do correct me if I’m wrong :sweat_smile:

If I’m not mistaken, if nvidia-dkms is the driver installed (the default?), having the kernel headers installed (as @ddnn instructed) should be sufficient, the dedicated nvidia-lts driver is not needed.

So long as the respective kernel headers are installed, the dkms driver will be built in accordingly without needing the kernel specific Nvidia driver.

To see what Nvidia packages are installed:

sudo pacman -Q | grep nvidia

1 Like

The dkms version was installed initially as far as I can tell. sudo pacman -Q | grep nvidia before changing to the lts version returned

nvidia-dkms 550.78-1
nvidia-hook 1.5-2
nvidia-inst 24-1
nvidia-settings 550.78-1
nvidia-utils 550.78-1

And now returns

nvidia-hook 1.5-2
nvidia-inst 24-1
nvidia-lts 1:550.78-3
nvidia-settings 550.78-1
nvidia-utils 550.78-1

Though I still boot using the lts option provided after following @ddnn’s instructions, this change does not seem to have made much of a change as far as I can tell.

I wouldn’t worry too much about this, to get this all you have to do is help out with some testing when the new releases are being worked on (I have this option but changed it back to regular just to stop this sort of confusion)


Yeah, I expect not much would change there. Just two different approaches to installing the Nvidia driver.

Adaptive driver (nvidia-dkms + headers) vs driver designed to work only with a specific kernel (nvidia-lts).

In your BIOS, perhaps try disabling “Fast Boot”.

You also have available to you, tools and kernels designed specifically for the Asus laptops. I can not vouch for these, as I’ve not tried this on my Asus Zenbook. Of particular interest, is the custom kernel mentioned further down this article (linux-g14). Note, that in order to use that kernel, you’d need to revert to using the nvidia-dkms driver.

Linux for ROG Notebooks

1 Like

I old people I don’t have the memory I once did lol.


Hello again! Thank you for linking that article!

I disabled fast boot in my bios and followed through the steps roughly as best I could. It led me to updating the kernel and installing a few things for use with Asus devices. I also reverted to nvidia-dkms as per your earlier comment, and changed my kernel to the g14 one as instructed in the article you linked :smiley:

Unfortunately, I still do not see any changes to the aforementioned issues. It stalled longer while trying to turn off for a reboot, and I made sure to log in using the g14 kernel but launch speeds for Welcome and Steam seem roughly the same if not a touch worse.

I additionally tried using the switcherooctl they mentioned in that article to run Steam- which as far as I can tell is very similar to prime-run which I have some familiarity with.

I don’t know if this is interesting or of any use or not, but after running switcherooctl launch steam, the console returned[3204]: Running Steam on endeavouros rolling 64-bit[3204]: STEAM_RUNTIME is enabled automatically[3281]: Steam runtime environment up-to-date![3204]: Steam client’s requirements are satisfied
[2024-05-20 19:38:46] Startup - updater built May 16 2024 20:10:34
[2024-05-20 19:38:46] Startup - Steam Client launched with: ‘/home/:smile:/.local/share/Steam/ubuntu12_32/steam’
05/20 19:38:46 minidumps folder is set to /tmp/dumps
05/20 19:38:46 Init: Installing breakpad exception handler for appid(steam)/version(1715891371)/tid(3331)
[2024-05-20 19:38:47] Loading cached metrics from disk (/home/:smile:/.local/share/Steam/package/steam_client_metrics.bin)
[2024-05-20 19:38:47] Using the following download hosts for Public, Realm steamglobal
[2024-05-20 19:38:47] 1., /, Realm ‘steamglobal’, weight was 1000, source = ‘update_hosts_cached.vdf’
[2024-05-20 19:38:47] 2., /client/, Realm ‘steamglobal’, weight was 1, source = ‘update_hosts_cached.vdf’
[2024-05-20 19:38:47] 3., /client/, Realm ‘steamglobal’, weight was 1, source = ‘baked in’
[2024-05-20 19:38:47] Verifying installation…
[2024-05-20 19:38:47] Verification complete
UpdateUI: skip show logo
Steam logging initialized: directory: /home/:smile:/.local/share/Steam/logs
/usr/share/themes/Breeze-Dark/gtk-2.0/widgets/entry:70: error: unexpected identifier ‘direction’, expected character ‘}’
/usr/share/themes/Breeze-Dark/gtk-2.0/widgets/styles:36: error: invalid string constant “combobox_entry”, expected valid string constant

(With :smile: naturally being my username)
The console then stopped producing messages for some time before eventually continuing with:

XRRGetOutputInfo Workaround: initialized with override: 0 real: 0xe29ccdc0
XRRGetCrtcInfo Workaround: initialized with override: 0 real: 0xe29cb500[3373]: === Mon May 20 07:41:14 PM EDT 2024 ===[3373]: Starting steamwebhelper under bootstrap sniper steam runtime at /home/:smile:/.local/share/Steam/ubuntu12_64/steam-runtime-sniper
CAppInfoCacheReadFromDiskThread took 38 milliseconds to initialize
Steam Runtime Launch Service: starting steam-runtime-launcher-service
Steam Runtime Launch Service: steam-runtime-launcher-service is running pid 3484
vkCreateInstance failed with error -9
BInit - Unable to initialize Vulkan![3634]: === Mon May 20 07:41:24 PM EDT 2024 ===[3634]: Starting steamwebhelper under bootstrap sniper steam runtime at /home/:smile:/.local/share/Steam/ubuntu12_64/steam-runtime-sniper
BRefreshApplicationsInLibrary 1: 1ms
BuildCompleteAppOverviewChange: 361 apps
RegisterForAppOverview 1: 5ms
RegisterForAppOverview 2: 6ms
[2024-05-20 19:43:15] Background update loop checking for update. . .
[2024-05-20 19:43:15] Checking for available updates…
[2024-05-20 19:43:15] Downloading manifest:
[2024-05-20 19:43:15] Manifest download: send request
[2024-05-20 19:43:15] Manifest download: waiting for download to finish
[2024-05-20 19:43:15] Manifest download: finished
[2024-05-20 19:43:15] Download skipped: /steam_client_ubuntu12?t=606823268 version 1715891371, installed version 1715891371, existing pending version 0
[2024-05-20 19:43:15] Nothing to do

(Hopefully I managed to avoid sending any sensitive info there :sweat_smile:)

So it doesn’t seem like running it with that helps ;w;

@Malva, if only emoji’s were legitimately usable as profile names :laughing: Someone should get that done… :stuck_out_tongue_winking_eye:

I wonder that sharing your boot log might shed some light on something. To grab your boot log, fresh restart then immediately run:
journalctl -k -b -0

To have it also automatically share it to a short-url service so you can link it here:
journalctl -k -b -0 | eos-sendlog

1 Like

Haha absolutely! I’d probably choose something cuter though like a :purple_heart: or something :smiling_face_with_three_hearts:

As for the logs you requested:

Please don’t hack me :innocent:

1 Like


1 Like

:face_holding_back_tears: Please? :face_holding_back_tears:


I wouldn’t have a clue on how to do that, so you’re safe from me. That and, unless I know who you are and I straight up despise you, I have no reason to. Even then, I probably wouldn’t.

Unless you’re a politician who is known to be an unethical :poop:.

I love how you reassure me and then immediately make me afraid for my life again :smiley:


From what I understand, most of the issues you’re encountering a performance related / delays, etc. Have you installed the Intel CPU driver (non-free, as in freedom)?

With that boot log, did you experience the keyboard/mouse issues on that boot? If not, it’d be good to see the boot log specific to when that issue arises.

I did note starting line #1136 of your boot log, it was throwing ACPI BIOS Errors.
kernel: ACPI BIOS Error (bug): Could not resolve symbol [\CTDP], AE_NOT_FOUND (20230628/psargs-330) ....

Some suggest the Intel CPU driver may help, but others have put it down to your hardware being too new for the kernel, or a BIOS update needed (but if I’m not mistaken, you’re already running the latest BIOS based on line #66) that’s where I’d hope the Asus specific kernel might help, but I can see you did use that in this boot (line #1).

1 Like