My PineBook Pro will not boot up

I’ve been waiting for this announcement because I wanted to help test for the Pinebook Pro. In the few days since we interacted on the ARM Plasma forum not only has my eMMC become unreadable, but my Pinebook Pro won’t start. I’m not sure when or if I’ll be able to help if something doesn’t change on my end.

If you have a micro SD laying round, simply install this image on the uSD.

Using Method 2 to install it to your uSD

Then insert the uSD into the PBP uSD slot and boot the laptop.

PineBook Pro always looks at the uSD slot first. If there is a bootable device present, it will boot from it. If there isn’t a bootable uSD present, it looks at the eMMC connector for a bootable device.

So if you install to a uSD card, and put it into the uSD slot, it should boot into EndeavourOS.
If this is the case, then the hardware is OK and likely the eMMC is corrupt.


I’ve dd’d the newest image to uSD and eMMC but the computer won’t start. That’s weird because it’s done literally nothing for a few days. It is fully charged.

@jc1685 I moved our posts to a new Topic. This will give this Topic more exposure.

After reading this Post on the pine64 forum, it looks like possible battery problems


A post was merged into an existing topic: EndeavourOS ARM is reworked and back in action

Does it show a red or orange blinking light?

Solid red light shows when plugged into the wall charger. After a while the red light turns off. Laptop will not even begin to boot up when I press the power button. I’ve short pressed and long pressed. I’ve tried with eMMC in and removed. I’ve tried with the eMMC switch on and off. The only thing I haven’t tried is disconnecting the battery and using the bypass, but I will be trying that today.

Another thing, I’ve dd’d the newest pbpro image to eMMC and uSD, but after doing that my PC doesn’t recognize the contents of either drive.

EDIT: After disconnecting the battery and connecting the bypass cables I long pressed power button to clear any residual power, for about 60 seconds. PBPro still would not power on when the power adapter was plugged in.

I guess there’s something more than minor going on. I don’t do any electrical troubleshooting so this may be it for my PBPro. :disappointed:

Have you tried a different OS in the SD card? I have a Debian one that has done the the trick when nothing else would, Manjaro sometimes is nicer to the pbp as well. I would remove the eMMC to test this, but my eMMC switch has never worked.

I’ve only tried EOS since I removed Manjaro from the eMMC. The thing that worries me is the Pinebook Pro doesn’t boot under any circumstance - see my comments above. Shouldn’t it at least attempt to power on and boot, regardless of what’s on the SD or eMMC?

It may boot depending on what’s on the SD or eMMC.

Was it working the last time you used it, and then some days after this is what you get?

Or was it working, then you did some kind of change and it stopped working?

The last time it booted was when I used the ARM Installer from the Live USB. I installed the LXDE version and didn’t like it. Reflashed the eMMC and attempted to install KDE Plasma and ran into errors. @Pudge informed me there were errors specifically with Plasma and it would probably be a few days until we could try Plasma again.

I turned off the PBPro and left it alone for a few days until yesterday, when Plasma was ready to experiment with again. At that point the PBPro would not start or boot. I let it charge about 24 hours and it still won’t power up or even attempt to boot.

Currently I’ve tried booting from eMMC and SD and neither works.


I have a good update: I was able to use Balena Etcher to write both Manjaro-Arm and Endeavour-Arm to two different SD cards and they both booted! Next I’ll be trying with the eMMC.

I’m not sure what happened with the dd command I used but that was probably one source of the problem. When I booted into EOS Arm it reported my battery at 0% even though I had it plugged in for more than 24 hours.

At this point I’ve turned it off and I’m going to let it charge. I’ll boot it again later and check the battery level and then go on to the eMMC possibly tomorrow.


Great, glad you got it going. Good luck with the battery charging. :crossed_fingers:

I am in the middle of compiling a pinebook pro kernel that will hopefully allow btrfs.
If this is the case, I will be releasing the rootfs tar image soon.