EndeavourOS ARM is reworked and back in action

Over the last few weeks, EndeavourOS has been in the perfect storm of bad Karma.
Finally all the problems have been taken care of.

EndeavourOS ARM is now using the new Galileo installer with KDE Plasma as the host Desktop Environment. The developers did an amazing job with Galileo and I think it is the most clean and professional looking installer version yet.

There are new Images for RPi 4b, Odroid N2, and Pinebook Pro. PLUS images for the Radxa ROCK 5B device. Yes we are now supporting a new device.

RPi 4b, Odroid N2, and Radxa ROCK 5B have both the rootfs image and ddimg images available.

PineBook Pro only has the ddimg image available. The PineBook Pro rootfs image is delayed as btrfs is not playing nice. If anyone has btrfs running on a PineBook Pro please contact me and give me a helping hand.

The EndeavourOS ARM installation page has been re-freshed.


What is needed now is volunteers with the above ARM devices to perform installation testing.
If you want to help out, do some test installs.

What ARM device was tested. What desktop environment was installed. What image format was used. If the image format was rootfs, did you install via the EnOS liveISO or manually download the rootfs installer then installed via running the install script.

Read the posts here to see what has been previously tested. Then report back here with your results and comments. Comments can include the new installation web page. If there was a Calamares failure, use the eos-log-tool to put the log on the internet. Then list the web address (such as https://termbin.com/sj5b) for the log.



I’ve been waiting for this announcement because I wanted to help test for the Pinebook Pro. In the few days since we interacted on the ARM Plasma forum not only has my eMMC become unreadable, but my Pinebook Pro won’t start. I’m not sure when or if I’ll be able to help if something doesn’t change on my end.


3 posts were split to a new topic: My PineBook Pro will not boot up

I’ll do a test install on a Pinebook Pro, SD card, as soon as I have the time, probably next Friday or Saturday.


The ARM Installer on the latest Live USB throws a 404 error when it tries to download the Pinebook Pro image.

I have been able to download the image from github and use dd to install it to SD and eMMC. Now if my PBPro would boot!

1 Like

I just tried to install the Dec. 5 version for Pinebook Pro (didn’t notice the new version from today) and got a time out error. Here’s the details: https://termbin.com/1r0r

Couldn’t shut down or reboot with the gui and konsole wouldn’t launch so I had to force a shutdown by holding the power button.

I just downloaded this ddimg

and installed KDE Plasma. Everything worked as expected.

Notice the Release said “fixed the kgamma5 to kgamma package name change”

I can also say that with the latest version of Pinebook Pro, a 256 GB micro SD cards works just fine. I have to retract that statement. Best to stick with 64 GB or 128 GB cards.

I can also say that my PineBook Pro works well so far with the 6.6.5-1 kernel. Which is the latest stable kernel version. I still have to test to see if btrfs is working with this kernel.



What’s the minimum size SD card that will work? I’ve been trying with a 16gb, just want to make sure that’s enough.

The installed size of most DE’s we offer are just under 8 GB. For doing test installs, 16 GB works. I do that quite often when trouble shooting the installer. That keeps the wear and tear off of the bigger uSD’s.

For a long term install, I consider 64 GB the minimum. Anything bigger than 64 GB is better.



I downloaded the newest ddimg for Pinebook Pro (12/08/23) and wrote the image to a USB drive, since my SD cards are either too small or had errors that couldn’t be reconciled. The installer ran without error and installed easily to the USB drive. I installed KDE Plasma.

Next is to install on my eMMC.

1 Like

If you are thinking about replacing your uSD cards, these have worked well for me.


What to look for: the U with a 3 in it. There are U1 U2 U3 with 3 being the highest speed. If it has U3 then it will probably also have the A2 and V30 designations. At amazon



The PineBook Pro kernel linux-eos-arm-6.6.5-1 is available and has btrfs enabled.

On existing installs on PBP the next time pacman udates the system, the new kernel will be installed.

In the next day or two, I hope to have thePineBook Pro rootfs tar image available.

This kernel is in need of a lot of testing. If you update to linux-eos-arm-6.6.5-1 let us know how it is going.


1 Like

I’ve installed Plasma in a into a 32 GB SD card running on my Pinebook Pro, using method 2 and ext4. All seems to be working well, and the installer is pretty neat!

I’ll go for a btrfs install next, with some other DE.


Can you explain the difference between the ddimg and the rootfs files?

A couple of items regarding installing the 12/08/23 version based on my experience:

  1. If I cancel the install to turn on wifi none of the icons work afterwards.
  2. The only way to shut down at that point is to force it with the power button.
  3. The image on the eMMC/SD won’t work afterwards, forcing another reinstall of the image to the eMMC/SD.

Thank you for taking time to test the images. I don’t have the rootfs tar image on github yet. Probably will be there today sometime.


Yes, Calamares does not like being cancelled. That is why on the Calamares launcher it says

             Ensure that you are connected to the internet
             before proceeding to the Calamares installer.

             Network connection options are available in the
             system tray on the bottom right of your screen.

             WiFi only users will need to choose a network
             and enter a password.


FIXED One bug I have found is the touch pad “Tap to click” is not enabled enabled in Plasma by default.
One has to go to “Settings” then “Input Devices” and finally “Touch pad”. There is a “Tap to click”
check box with no check mark. Click in the box to enable Tap to click"

I need to see about fixing that today. FIXED

1 Like

Tap to click is much better, but I didn’t see it not being active by default as a bug, only as a choice.

I will try btrfs when you say it’s ready. Thanks!

1 Like

Cant put into words just how much I love the arm version. Especially when you consider the alternatives.

I have it running on both an Odroid N2+ and a Pi400. Latest kernels…Everything works perfectly.


1 Like

I have pushed the PineBook Pro rootfs tar image to github.

Instructions here


I have tested
Method 1 liveISO - Gnome on btrfs 128 GB uSD
Method 3 download installer - i3wm on ext4 on 128 GB uSD

As of now, I don’t recommend a 256 GB uSD. After more testing they seem to be kind of flakey.


1 Like

Tomorrow I should get my Raspberry Pi 5 delivered. I am anxious to see how it compares to the RPi 4b.


1 Like