My installation is broken

Hi guys,

First of all, I have been using this distro for many months and I quite enjoy it.
I have recently made an update for packages which also updated the release to Atlantis, from what it looked like, after laptop restarted it frooze for a while then I forced shutdown, now, whatever I do I can not get back neither the wifi, the audio (hangs at trying to connect to pulseaudio) and I can not run any sudo commands.

Here is what I have tried:

  • Upon a suggestion I have booted the distro installation in a USB and run gparted and did the check for the partition but it had no effect.
  • Somehow yesterday as in doubt keep restarting did manage to get it working then proceded to install more updates which again after restart the same problems again.
  • Looked everwhere and did not found a solution, some required running sudo commands but I cannot run sudo even as a root user.

All what I think of now is to copy files I do not want lost and do a fresh install, but I would appreciate another solution.

Welcome to the forum!

You definitely need to update more frequently. When you update after months of not updating it makes the update process much more risky.

Can you share the exact error you get when you try to run a command with sudo?

I agree, a lesson learned.

Running sudo commands does nothing, I press enter and keep waiting but nothing happens, no errors.

Try this in a terminal

  • Type su
  • Enter your root password
  • Once you get the # prompt. Try pacman -Syu

This worked, awesome
Still no wifi nor ethernet connection work

1 Like

Can we see the output of:

inxi -n
pacman -Q | grep -i network

the inxi one does not work.

As for pacmac it returns:
glib-network 1:2.70.1-1
network-manager-applet 1.24.0-1
networkmanager 1.34.0-1
networkmanager-openvpn 1.8.16-1

How about:

nmcli -o

It does work, it does suggest me to run other commands which they work both but they do not return anything

Can you share the full output of the command here so we can see what you are seeing?

Use “nmcli device show” to get complete information about known devices and “nmcli connection show” to get overview on active connection profiles.

Consult nmcli(1) and nmcli-examples(7) manual pages for complete usage details.

I need to see the part where you typed the command too.

It looks like your network devices aren’t being detected.

Yes, so…looks like a reinstall then

Almost definitely fixable.

I would start a new topic about your network issues because the people who are the most knowledgeable about that might not read a topic called “My installation is broken”

1 Like

Please do and give me a link, if nothing work I will have to reinstall and get back my setup up and running before the week.

Thank you for your time, I appreciate your effort of helping me.

Just to be clear, I meant that you should open a new topic describing your network issue.

3 Likes

Thank you for the clarification,

One more thing to add that’s not just related to network is that on shutdown it shows this:

Can we see the output of:

systemctl list-units --failed