My experience with browsers on Linux is terrible

Granted: I’m not English, so sorry for the grammar. If you have any doubts about what I wrote, ask without problems

Hi, I have been a Linux user for many years and then abandoned it for various reasons (mainly due to the breakdown of the pc and the wrong purchase of a computer not compatible with Linux)
In any case, I now have a computer that is 100% compatible with Linux drivers and I “desperately” want to go back, in fact I have installed it, but I have noticed that the browser experience is tremendously slow and laggy compared to Windows (especially with chromium and chrome)
The main problem is that when I open a lot of tabs (even “only” 6 or 7 ") the interface becomes cumbersome. If I close a tab it takes a second to close, it is not instantaneous. (even if I open a tabs)

The problem obviously gets worse when I’m watching videos, despite having hardware acceleration enabled (on X11)

KDE Plasma Version: 5.22.3
KDE Frameworks Version: 5.84.0
Qt Version: 5.15.2
Kernel Version: 5.10.52-1-lts (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Core™ i3-5005U CPU @ 2.00GHz
Memory: 7.7 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 5500

(Yes, I know my system is quite dated, but on Windows the browser is very fast. I’m just saying this for comparison, I don’t want to say which is better or worse in general)

Below I will list the attempts I have made so far to improve the situation:

  1. I have tried with and without xf86-video-intel

  2. I tried to disable VSYNC

  3. I tried with the options “Tearfree True”, NoAccel True, DRI False and AccelMethod to UXA

  4. I installed the intel-media-driver, libva-intel-driver, gstreamer-vaapi libvdpau-va-gl and intel-hybrid-codec-driver drivers

  5. I also tried with the newer linux kernel, not lts

  6. I think it is useless to specify it, but for safety I do: I also installed and activated cpupower and thermald

  7. I added these flags to chromium-flags.conf

–force-device-scale-factor=1.2
–enable-features=WebUIDarkMode
–force-dark-mode
–ignore-gpu-blocklist
–enable-gpu-rasterization
–enable-zero-copy
–disable-gpu-driver-bug-workarounds
–enable-accelerated-video-decode
–enable-features=VaapiVideoDecoder

I don’t use --use-gl=desktop because videos give me trouble very often

  1. I use the cache mounted in tmpfs, but I also tried using the cache on SSD

  2. Extensions installed: Bitwarden, Ublock Origin, Popupblocker, Dark Reader, Plasma Integration, h264ify (the same on Windows with Chrome)

This is my chrome://gpu

Gpu

This is gpu_tools_top when I watch a video.
Usually when the video part is running the GPU should be enabled, it seems to me

Firefox is slightly better, but under a lot of stress it slows down too
I would prefer to use Chromium

I honestly don’t know what else to do, this is probably the only problem I have that prevents me from using it as my main system. A browser that slow when put under stress is almost unusable

Thanks for the help

Hello,

Seems you’re using KDE on top of an Intel integrated GPU. KDE is a resource-intensive and integrated GPU from Intel that is not that good (old once at least).

Newer browsers and online players use the GPU power more than they use the CPU to play content. Also, using Chrome or Chromium is not helping because both eat up memory when many tabs get opened up.

In W1nd0ws it’s different how they handle the memory and resources. And W1nod0ws does a lot of paging or catching to the drive when it runs out of memory to keep the on-focus app running smoothly.

Hope you have a SWAP partition or a file in place because you have 8 GB of RAM and using KDE. Also, try other browsers like Vivaldi or [Brave](https://brave browser). Both are based on the Chromium web rendering engine but optimized better than the two flagship browsers.

Or if you want to go down the Firefox path you can use LibreWolf or WaterFox.

2 Likes

Not really, it’s about as XFCE this days, as long if everything is right…

4 Likes

I run KDE with Intel integrated graphics at the moment. I have no problems related to that.

2 Likes

Hi, thanks for the reply

I know that KDE is not that light, but I thought it was enough on a PC that can run w10 very well

Yes, I have the swap. Although I tried to remove it to see if the problem was the activation of the swap file which was slowing down the system

I’ll try the other browsers too, although to be honest I’m not very keen on doing such a radical browser change

@Shjim what’s the facepalming for? I just don’t have the finances to buy a new graphics card at this time ! :laughing:

Have you tried using just the modestting by removing intel driver?

Edit: I am referring to xf86-video-intel

Yes, usually my base installation is without xf86-video-intel, but on this occasion I tried to install it to see if anything would change

Besides trying things with your GPU, you might want to look into how your CPU is being managed. Install s-tui (yay s-tui should install it) and do some browser activity. s-tui should show you in real time what frequencies your cpu reaches. it may be the case that the cpu is running in power saving mode and doesn’t reach its full potential.

1 Like

KDE nowadays is one of the lightest desktop environments (it’s lighter than XFCE and GNOME, certainly). This is, of course, not counting the minimalist ones like dwm (yes dwm is an extremely minimalist DE, prove me wrong :rofl:)

Try Firefox.

3 Likes

Thanks for suggest, but i admit i am a noob with this software
I post you a screenshot, what should I see?

Edit: I gave this command:

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors
And the result is: conservative ondemand userspace powersave performance schedutil

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

schedutil

@Salvaju29ro
Have you tried the following kernel parameter in the default grub command line? You’ll have to add it and update grub to see if it makes any difference.

i915.enable_psr=0

Sometimes it solves flickering issues or freezing but may also help with lag.

Edit: https://discovery.endeavouros.com/intel-gpu/intel/2021/03/

well my assumption was that powersaving is preventing your cpu from reaching its nominal frequency. from the screenshot it looks like it’s set up ok. schedutil should be a pretty well balanced CPU governor, and from the graphs you can see the CPU is not saturated. probably the issue lies somewhere else.

1 Like

Welcome to the forum! :smile:

A quick question: is hardware acceleration enabled in your browser?

2 Likes

@ricklinux I’ve tried the parameter and it doesn’t seem to work

@nate I tried to set “performance” to frequency but I don’t think it improved. I wouldn’t want to fall into a placebo effect by noticing small improvements

@manuel Yes, I posted everything I did in the main topic

I monitored the CPU while opening a single Chromium tab and noticed it suddenly pops up for a second.
I don’t know if this is normal

Cpu

Did you try all these kernel parameters?

options i915 enable_dc=0

options i915 enable_fbc=0

options i915 enable_psr=0

options intel_idle max_cstate=1

@ricklinux Sorry, do I have to try them together or do I have to try one at a time?

You can at times have more than one but i think i would try them separate based on the fact that each does something slightly different. I know it’s time consuming and a little bit of pain but, it’s trial and error until you find a solution.

You are down to the “Kraft Dinner” approach to problem solving now… that is: throw it at the wall and see what sticks! Often one of them will…

@ricklinux with i915 enable_fbc=0 and sudo cpupower frequency-set -g performance there is a very slight improvement.

But, as I said above, I’m afraid it could be a placebo effect of my brain: D.

In any case, it’s not exactly super fast. There is always some lag, especially when I open and close the tabs (and at that moment the CPU squirts for a second at 90%)

In any case, I’m afraid my hardware is simply poorly optimized for Linux browsers

Edit: it was actually a placebo effect, it’s as laggy as before

Thanks for the tip anyway