My EOS Journey Diary

Hi Friends,

Since I am new to EOS, I thought I can journal my journey. Maybe others can learn from my victories and my mistakes. I’m sure there will be comedy involved as well.

First, let me give my notebook specs:


As noted before, I came from the Pop!OS realm and I am sort of familiar with the Linux multiverse.

I am not an expert by far…I would say I am sorta immediate-ish. I stick with situations for a while to figure out why something doesn’t work. If I tap out, the only reason why is because I have exhausted all options.

Let’s start off officially making today Day 1 (even if I have ran EOS for two days now).

Day 1:

Since the borking of PopOS, I needed to install Signal (available as a Flatpak). I followed the instructions from both Discovery EOS webpage and Flatpak webpage.

The result?

:partying_face: Success! :partying_face:

The other win today? I connected my Bluetooth speaker following the instructions from Discovery and I got this to work too! Woo Hoo!

On Pop OS, I also had Vivaldi, Steam, Thunderbird. I may tackle those installations soon.

I’m also gearing up for the ginormous gaming challenge that will be posted in the Gaming section. Stay tuned for that if you are interested. This involves trying to get a game work that I ran on Lutris and now it is not. Fun times. Le sigh.

Thanks for reading!

  • RoRo

I only have one question. How could anyone bork PopOS? :laughing:



No problemo, just use portable wine (version which works with specific game)

Also read the guide if it helps Linux gaming [Guide] :upside_down_face:


LTT did it in front of millions of viewers :rofl::rofl::rofl:


@RokettoPanchi Linus, is that you? :rofl:


Don’t underestimate my borking abilities with Linux. :sweat_smile:

1 Like

It’s…complicated. Le sigh. :pensive:

Vivaldi and thunderbird are a piece of cake to install with pacman. :wink:

1 Like

Cool…so this means that @flyingcakes will be delivering them then. :sweat_smile:


I had installed it directly, without ever thinking of flatpak, as described by @manuel. It is very straightforward for me to install directly via yay or pacman, in comparison with enabling flatpaks.
The reason is funny though; I don’t like that method because it involves more typing of the alphabets, which discourages me to think of it.

@flyingcakes will need to take proper precautions as there are heat wave alert across various parts here!!

1 Like

On my way :saluting_face:

True :sweat_smile:

1 Like

:stars: Star Date: -300563.16397133446 :stars:

Salutations Friends!

Another day and another day to be in the school of EOS!

Here’s a quick nightly recap:

Firefox was acting wonky and I kept wondering why I had .json files accumulating in the Download folder. Then I remembered that I had saved and changed FF settings to harden the browser and I accidentally placed the directory to save profiles in…you guessed it…the Downloads folder. :man_facepalming:t6:

In addition, I had hardened FF too much and some sites were all like…NOPE.

So, I uninstalled FF then re-installed. I added add-ons for security and I did not harden the browser like before. My threat model is adequate for right now.

Next, since I am a gamer…I went to tackle downloading Steam. :steam_locomotive:

I downloaded Steam from terminal. I downloaded a game in my library. I click ‘launch.’ Nope. I opened up properties and placed %command gamemoderun. Still no go. I uninstalled Steam and researched on why games were not launching on an arch linux rig. I found one Steam forum post where the end user stated using Flatpak Steam solved his game launch issues. I downloaded the fp version then went to bed. I’m amazed how fast my notebook shuts down since using EOS. :fast_forward:

This morning I logged in and realized I did not download gamemode which may had caused the original Steam client not to launch. I went to terminal, downloaded gamemode using yay, and then logged into Steam.

I downloaded my game, placed the gamemode command, and…

The game launched! :man_dancing:t6:

Slowly yet surely I’m learning!

Nest, I am considering creating a standard account so I will stop using my admin account on here. I am on the fence about this. I know using the admin account can be risky…as far as the easy path is concerned, I wouldn’t have to log into another account.

Any thoughts on this?

Thank you for reading. I appreciate each of you.


tl;dr: I Google, I Fix, I Play, Hooray! :+1: :enos:

1 Like

Using root account constantly is risky and not recommended.

You should create a less privileged account (with wheel group) and use sudo whenever you need to do something that requires elevated privileges. Sudo keeps the elevated privileges for some time (a few minutes) so it is not a one liner; you can run several sudo commands without re-writing your password.

Using one liner

su -c "command-needing-more-power"

is also possible, when you don’t want to keep the privileges beyond one command.

In EndeavourOS you can use also su-c_wrapper which works like su -c but the command syntax is more like with sudo. More info about this with command:

eos-apps-info-helper su-c_wrapper
1 Like

Would I use this command to create a less privileged account?

useradd -m -G additional_groups -s login_shell username

P.S. I looked for a MATE user-management yet it will not download the groups package. :frowning:

1 Like

I wonder if creating a new account is necessary when you could just occasionally get elevated rights and do some sudo stuff and fall back to the “normal” user afterwards.
Or is it that you want an account without any sudo capacity at all?

Just a standard account and if I need to play a deep surgeon, I could log into my root account.

1 Like

yes it will create users home sets the shell…

useradd -m -G wheel -s /bin/bash *username* would be the standard creation … so user would be able to use admin rights …

:stars: Stardate: -300560.46962201933 :stars:

:sun_with_face: Bon Matin Friends! :sun_with_face:

Time for another update on my EOS Journey.

Here is what I have done thus far (in bullet form because most people like a TL:DR approach).

  • I was able to create a standard account by following these instructions. Shout out to @manuel & @joekamprad for additional insights.
  • I downloaded flatpak Steam on the standard, downloaded Hardcore Mecha from my library and it loaded. I am curious why the sound is choppy when I am in game play.

My current hit list (“to do list”):

  • Figure out how to connect wi-fi.
  • Figure out how to connect my printer.
  • Open a thread in EOS Gaming about my software challenge that I will be facing with a game I use to play (its no longer working) and how to overcome it.

Thanks for reading!

I figured out that pulseaudio was completing with pipewire.

I used these tips from the Wiki by making pulseaudio primary and now the sound is as clear!


Victory Yes GIF

1 Like