My EndeavorOS Not Showing All Wi-Fi Network

I just tried EndeavorOS live-usb from now.
But, when i tried to connect any network, it doesn’t show.

To me, it looks like it has your network device down. Type ip link into your terminal and post the results.

2 Likes

You might want to have a look here https://wiki.archlinux.org/title/Broadcom_wireless

3 Likes

brcm80211

The kernel contains two built-in open-source drivers: brcmfmac for native FullMAC and brcmsmac for mac80211-based SoftMAC. They should be automatically loaded when booting.

Note:

  • brcmfmac supports newer chipsets, and supports AP mode, P2P mode, or hardware encryption.
  • brcmsmac only supports old chipsets like BCM4313, BCM43224, BCM43225.

Your chip should be using a kernel module brmsmac automatically loaded on boot. The broadcom-wl maybe interfering or other broadcom modules that need to be blacklisted.

You can try rmmod wl
Also your ethernet is down. The correct module is atl1c which you could try modprobe acl1c

https://wiki.archlinux.org/title/Broadcom_wireless#brcm80211

https://wiki.archlinux.org/title/Kernel_module#Manual_module_handling

4 Likes

Here is the result of ip addr command:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp6s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN mode DEFAULT group default qlen 1000
link/ether b8:70:f4:98:6a:6b brd ff:ff:ff:ff:ff:ff

1 Like

So it is up. You’re using networkmanager? I had a similar problem, my wlan0 was disabled in

/etc/NetworkManager/NetworkManager.conf

Don’t think that’s the issue here, but checking doesn’t hurt. :wink:

3 Likes

Eum…
The file NetworkManager.conf doesn’t have any code to disable or anything in here :confused:

So, what can i do? :no_mouth:

1 Like

What does

iw dev

show?

1 Like

no output :frowning:

1 Like

in terminal . type " rfkill list " possible blocked ( if soft ) use " rfkill unblock wifi "

2 Likes

no one has blocked :frowning:

0: acer-wireless: Wireless LAN
Soft blocked: no
Hard blocked: no

1 Like

I have a similar problem.
It is a new laptop (Lenovo E15 G3 with AMD Ryzen 5).
Running inxi -Nn shows following result:

Network:
  Device-1: Realtek RTL8111/8168/8411PCI Express Gigabit Ethernet driver: r8169
  IF: enp2s0 state: down mac: xx:xx:xx:xx:xx:xx
  Device-2: Realtek driver: N/A

I checked that Wi-Fi is a RTL8852AE. There is a driver in the AUR. I am able to install it in the live system using temporarily the ethernet adapter. Installation went well and Wi-Fi turns on. I am able to connect to my Wi-Fi router. After unplugging the ethernet cable I do not get any internet connection.

Is there any solution to install EOS via this WiFi-connection?

The WiFi is the new AX standard WiFi 6. You need the package rtw89-dkms-git from the AUR. You should be able to down load it and save it to a usb or someway and then be able to install it. I think @dalto would be able to explain how to build the package and install.

Edit: Is this the package that you used?

1 Like

After you install the driver and disconnect the ethernet, we probably need to take a look at the network then. Is the interface up? Do you still have an IP? Is it a gateway issue, etc?

You may be better off installing the system on the wired connection and trying to get it working afterwards. The fact that you can’t reboot to test anything in the live environment because it will remove the drivers is going to be somewhat painful.

1 Like

I wasn’t sure if installing it from the live environment keeps it after booting into the system or is it only running in the live session?

As far as I know, it is only running in the live session.

Can you not download the package from the AUR in the live session and save it to a usb drive and then boot into the system and install it. I’m not that familiar with the process so that is why i confer to you. Can’t you build it from the download and install it after booting into the installation?

You can build the package and then save the built package and install it after the fact. You could even chroot into the system before rebooting and install it right then. You don’t need to put on an external device. However, if being wired is an option temporarily, that seems a lot easier.

Okay i guess that is what confused me that if ethernet is available then just install it on ethernet after booting into the installed system. If it was installed on the live session and the WiFi worked but as soon as you reboot it’s gone if it’s only in the live session. So as you say on ethernet you can then install the AUR package and voila!

1 Like

After installing rtw89-dkms-git and disconnecting the ethernet I get following:

[liveuser@eos-2021.04.17 ~]$ inxi -Nn
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
           IF: enp2s0 state: down mac: xx:xx:xx:xx:xx:xx 
           Device-2: Realtek driver: rtw89_pci 
           IF: wlan0 state: up mac: xx:xx:xx:xx:xx:xx 
[liveuser@eos-2021.04.17 ~]$ ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN mode DEFAULT group default qlen 1000
    link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
4: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DORMANT group default qlen 1000
    link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff

Any hints?

Uuhhh!
That was not the answer I expected. :wink:
I wanted to avoid installing with ethernet, because after the installation the laptop will be only used via Wi-Fi.