My Dell Laptop network adapters not recognized

My laptop WiFi adapter on board one has been disabled by IoT satellite mode hack. I just left it untouched. Yesterday they disabled LAN adaptor as well. Even in live environment, network adapter remains un recognizable. Still i want to give it a try. Hence installed latest 6.71.archlinux based leo OS this morning. Results are the same. This has got nothing to do with Endeavor OS. Hackers have been able to disable on board NIC with some laser infused control. Network hardware stopped communicating with motherboard. Should i flash CMOS software? I wonder with out Windows OS it may not work. Designed for that only. Low level format doubtful. Should i try external WiFi card? Suggest most practical solution as i won’t be using this laptop after 2 months. I will be recycling in another country than the current country of living which is India, after migration which is due in 2 month time. I won’t pay a penny here in India for repairs. Thannks guy’s all over world.

First of all what i’d try is:

  1. Reset BIOS settings completely, save it, reboot back into BIOS
  2. Disable Secure boot, save it, reboot
  3. Boot into OS and see if that helps

Then see what’s in

journalctl -p3 -xb
1 Like

Several times bios settings have been reset to default. Secure boot has never been enabled. It doesn’t work fy this OS and laptopLegacy boot enabled.
Live environment using USB boot device also not recognizing network devices.
Qualcomm WiFi device not in PCI list.
IRQ 40,41 assigned to PCI bridge are not in interrupts.
Ethernet controller IRQ 45 appears in interrupts. No conflicts. Still not recognized. eno1 is LAN name.
Tried journalctl -p3 - xb
i801_smbus 0000:00:1f:.3: transaction time out is error

Video with all system information
Link on X