Mp4-video plays too fast

I have never experienced this before, having used it across three computers over two years on Arch-based systems… But after my latest install MPV plays all videos just a sliiight too fast. Not out of sync, audio and video is perfectly synced. But it plays just too fast. You can tell the difference in pitch of singers for example listening to the same song on youtube.

I have searched for suggestions online and some people have experienced it over the years but no solution have been presented as far as I can find.

Edit: Seems to be the case with all video players (well Parole does it as well, at least). Works well in Firefox was well. Problem with Nvidia / ffmpeg?

Edit again: installed VLC: It too plays too fast but also stutters noticeable, like it doesn’t like playing the video that fast but has to “catch up”, pausing for .1 second every 2 seconds or so.

Kind of a dumb question, but probably something good to check off of the list… have you rebooted? I had issues watching YT videos once and then realized I hadn’t rebooted since the last update. I rebooted and all was well.

1 Like

What graphics card do you use and which driver runs it?
What is the selected output module (vdpau, opengl, vaapi, …)?
It is not necessarily a graphic/video issue. Could also be a sound/pulseaudio issue.
Could you paste the output of

inxi -GA
yay -Qs mpv
yay -Qs mplayer
yay -Qs codec
1 Like

I did some research.

Observation 1: It is not the video, per se. but the audio. All digital audio output (mpv, spotify (audio only), VLC, Chromium) except in Firefox specifically is too fast. No matter if audio or video with audio.

Observation 2: Switching audio output to screen speakers via HDMI and then back again makes Firefox also play sound too fast. My guess is it triggers some hardware rendering by switching devices.

Observation 3: My wife just told me that on Windows 10 her Bluetooth headset makes Spotify play songs just a tad too fast as well.

Experiment 1: Setting my USB headphones to use analog output sound - Result… better but not good enough.

Experiment 2: Also turning off HDMI sound “device” in mixer - …sliiightly better still but not good.

Experiment 3: Replacing USB headset with analog 3.5 mm plug headset - Perfect sound.

As long as the 3.1 mm plug works, that is a simple enough solution.
Without digging deeper atm, my suspicion is that it has something to do with sound drivers. I do not have this problem in Windows 10 nor did I have it when running Fedora Gnome.
SO… Kernel difference in general (Fedora is on the Edge, but not BLEEDING Edge with it’s kernels), Gnomes implementation of sound drivers, or an Arch issue in general?

Again, not digging deeper right now since the easiest solution was well… easiest.

1 Like

I would rename the folder ~/.config/pulse to ~/.config/pulse.old. Then log out and log in again. So pulseaudio starts with default settings. It might be that something messed up your settings.
What confuses me is that you are the only one observing this behaviour.

That is in the end a worthless observation. Comparing two OSs when it’s up to bugs like these, rarely makes any sense(literally never).

I’m not, but apparently it’s rare. Last observation I found regarding Arch was from 2019 and the solution then was to add


at the end of

load-module module-udev-detect 

But that did not make a difference for me.

This did NOT work. The problem is obviously connected to any form of digital output. The only device tha sounds right is the 3.5 mm analog headphones.

Did you just recently do a kernel or firmware update?
Did you try to boot with LTS kernel?

Well yes, I switched from Fedora to Arch a week ago so that made me definitely update my kernel :wink:
(Seriously: yes, I jumped from Fedora 5.9.13 to Arch Latest. However, It is worth noting that I did also switch to the Zen kernel a few days ago and have only listened to youtube after that.

So I think it is quite obvious, what would be worth a try next.
I would install stable and LTS kernel and give those a try. :wink:
If that doesn’t work either, I would consider a fresh installation. I guess it’s never a good idea to switch distros the way you did. :laughing:

What advantages is kernel zen supposed to offer compared to the “normal” ones?

It IS a fresh installation.
Anyway. I won’t go to an LTS. If that fixes it, I might as well just use the 3.5mm plug until it gets fixed in a later update.

Switching to regular Linux instead of Linux-zen did not solve the issue however; from my estimation the playback when using a digital audo device (HDMI screen or USB headset) is roughly 1.5 second per minute, meaning the song or video reaches the 1 minute point at 0:58.5.

Okay. So I misunderstood your earlier statement.

1 Like

There’s an old bug report about Firefox playback being limited to 44.1Hz or 48Hz:

This makes me think it might be related to the playback sample frequency, e.g. Firefox is playing at 44.1Hz but other digital outputs are being played back at an incorrect higher rate? (This could also explain the slightly WIndows 10+Bluetooth sound if playing back at 48Hz instead of 44.1Hz.)

Have you tried setting default-sample-rate to your card’s native output rate, or setting avoid-resampling = true ?

Another idea would be to check some other Pulseaudio settings e.g. based on suggestions in this thead:

1 Like

Unfortunately nothing of that worked.

However… installing and connecting the headphones over bluetooth (they work both on cable and bluetooth and using bluetooth in Linux is a pain) works.

So now I only use the cable for charging the headphones, while the sound goes via bluetooth…

OH btw, a note to any wiki editor reading this: I might be blind, but there is no comment in the bluetooth wiki section that the package for pulseaudio needs to be installed for well… pulseaudo to find headphonees or speakers using bluetooth.

1 Like

I use blue tooth for Headphones and a audio amp no connectivity problems, well bluetooth connects better than w10. For firefox you need pulseaudio-bluetooth. If you are not using Pulseaudio well you are just shooting yourself in the foot

I know. And not only for Firefox. No sound on bluetooth unless that was installed, that was my point.
Anyway, this workaround did not help either; I get micro sutterings in my bluetooth, probably from being too close to a 2.4Ghz wifi.

So, for the time being I guess i will try to find a good quality analog headset with a 3.5 mm plug… :frowning:

@jonathon @Trekkie00

I cracked it!!!

The key was in the daemon.conf, but the opposite of what seemed logical: Locking the resample to 48k did the trick:

default-sample-rate = 48000
alternate-sample-rate = 48000

Still not sure why, but hey…


I think the wiki covers it very well


In order to be able to use audio equipment like bluetooth headphones or speakers, you need to install the additional pulseaudio-bluetooth package. With a default PulseAudio installation you should immediately be able to stream audio from a bluetooth device to your speakers.

You may also need to install this package from AUR pulseaudio-bt-auto-enable-a2dp this will make sure bluetooth does not drop from HIFI audio should have been fixed.

May I add a recommendation for the bluetooth-autoconnect package from the AUR, to get the same functionality as Windows, aka keyboards, mice, headphones that are paired connects automatically if turned on at boot?

So it was the sample rate then. :joy:

1 Like