Moving files from Btrfs (zstd compressed) is taking forever


I’m copying a ‘huge’ (almost) repertory (with files) from my endeavouros install, which is running on an SSD using btrfs file system (with zstd compression type), to and external HDD plugged on USB3.0.
It is going at a really really slow pace.
So i did try with other files, on another computer (same file system) with other drives. Same same…

Is it expected behavior then?
I guess asking the question is answering it… but if it actually is, is there some tweaks to be done to hope gaining some time moving files away?

(I did check btrfs wiki but couldn’t really find anything)


Can we define slow here?

What level of zstd compression are you using? Unless you set it at at high level I don’t think it would have much impact on sustained write performance unless your CPU is very slow.

1 Like

It’s set on default compression (which is 3 i guess).
And no, cpu ain’t that slow and i tried on my other machine with recent 10th gen i5 (i mean it’s ‘ok’).

Of course reading my post i realize it’s very subjective ^^
I could measure the output of course, but it is very very (very) slow. Even if i move ‘only’ a couple of gigs. I dunno, like 25min for 4go (not even 100 files).
Looks like it is exponential with the amount of files and/or the size cause i’ve ask for 130Go (w/ many files) 10h ago and it’s still running… but, again, i should measure indeed.

P.S.: if i look at glances the cpu is under no load, memory neither, but there is High CPU I/O waiting message. I tried with other disk (hdd, ssd, usb stick), other machine but with exact same install. Input devices being SSDs with btrfs and the output devices ntfs (i guess… maybe fat)

That should be fastest way to copy (outside of other factors)

rsync -aHAX --info=progress2 "SOURCE_DIR" "DESTINATION_DIR"
1 Like

All USB 3.0 external drives are not equal. What rpm is this hard drive, also the port it is plugged in on can make a big difference. Low rpm drives will make it seem like forever very quickly.

1 Like

Will definetly try. Was using cp.

Indeed. Mines are just crapy average, 5400rpm, hence my expectations are of course low. But it is far from what it should ‘at least’ be capable of.
I did try w/ flash drive and ssd too (both external) and with my other install.
And if i boot in windows (on the same drive of the same machine) the transfer rates are normal with those same drives.

1 Like

Btw, you can run kdiskmark with 32 MiB SEQ1M Q8T1 to have some understanding of your current average disk r/w speed

1 Like