Mounting error after installing

I’ve recently have been trying to install EndevourOS into my Lenovo Yoga 7i, however there seems to be a mounting issue that us occure whether in dual boot or clean install. It boots almost pefectly on debian based distros, but for arch, it has problems like this.

The laptop mentioned has been documented on the arch wiki (https://wiki.archlinux.org/title/Lenovo_Yoga_7i), which tells me that it is possible, but it doesn’t tell much about the situation. A quick look on the Yoga series’ Wikipedia page has noted such situation within the line of products due to a RAID drivers(?) by Intel.

Hello @Plan_808
It looks like it may have the wrong UUID entered in the fstab file. You’ll have to arch-chroot into the installed system and check what it has listed in the fstab compared to what the command lsblk -l gives for the / partition.

It could be that this system uses ‘fake RAID’ by Intel - which might cause problems. Do other systems/distros need to be on this computer?

1 Like

Fake Raid = Software Raid :wink:

Edit: It’s an Intel thing!

Hello

Thank you for replying. I will try that method once I have some time on my hands, and I will let you know.

I have tried kubuntu and FerenOS, and have booted properly, so I know that it is possible to run linux in general on the laptop.

Wouldn’t that block the install though if it couldn’t find the controller?

No really. Software raid is better :slight_smile:

Well i mean their implementation of fake raid on the hardware sucks!

I should have asked this before, but how do I arch-chroot?

2 Likes

On your original install hopefully in UEFI settings secure boot and fast boot have been disabled and SATA mode is set for AHCI not Raid. If you arch-chroot into it you can check and set the right UUID for the drive in fstab. Then update grub with the proper command.

Edit: Also if there is a setting for RST (Intel Rapid Storage) then try disabling it.

Usually the Intel Rapid Storage thing will prevent drives from showing up in the installer, so I’m doubting that is the issue here.

Souce: Owner of a laptop with intel RST

I don’t think there is a setting like that on my laptop.

I tried to chroot arch, but it seems to not have worksed as it got the same problem after installing it.

Did you change the uuid to match?

We have had a few users with this hardware setup that have been unable to get eos or any other arch distro installed. You didn’t have this issue?

I did have an issue (before I figured out what was happening), but what it looks like is when you go into the installer it does not show any of your hard drive partitions at all, just the installer media, so the OP wouldn’t have even gotten as far as having a fstab file at all. It also would look the same in Ubuntu/pop/whatever other distro because none of them are set up to deal with Intel RST.

It makes the system act like there’s no hard drive installed because by default the kernel has no clue what it’s looking at

I agree this isn’t exactly that issue. Others have had exactly what you are referring to. Others also have had the issue of the incorrect UUID. Not sure why?

i have seen such issue before users installing onto existing raid, installing was working but it was not possible to boot into Linux…

Should be possible to disable raid in the firmware or not ?

For some reason however, Ubuntu based distros have installed properly on my Yoga 7i as I stated in my original post. Said distros were kubuntu and Feren OS (based on Linux Mint, but not much difference, to an extent, since Mint is based on Ubuntu).