Monitor Refresh Rate stuck

I am running the Budgie DE on EndeavorOS and I am unable to change my monitor refresh rate. It is stuck at 59.97. I try to set to 99.98 and I get a black screen then screen come back and it is still set to 59.97. I run xrandr and it shows my monitor should support the higher refresh rate.

glxinfo | grep OpenGL
OpenGL vendor string: Intel
OpenGL renderer string: Mesa Intel(R) Graphics (ADL GT2)
OpenGL core profile version string: 4.6 (Core Profile) Mesa 23.1.1
OpenGL core profile shading language version string: 4.60
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6 (Compatibility Profile) Mesa 23.1.1
OpenGL shading language version string: 4.60
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 23.1.1
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:

I was able to get it fixed by installing lxrandr and setting the refresh rate from that and it worked. Only issue is after reboot it reverted back to 59.97 refresh rate.

Here is another user reporting n issues with changing monitor settings via budgie-control-center:

Yea I rebooted and it now reverted back to the lower refresh rate. Not sure how to fix this.

Not a budgie user here, so I’m afraid I cannot be of help to you.

If no other users will come along with a viable solution, you might want to consider filing a bug report to the developers:

There is no fix from research as its related to a dependency creating issues with its latest version, bug existed on Fedora Spin which is now fixed, not for us just yet. I left a comment on this report and I suggest you do too to get their attention

1 Like

I have also opened a ticket here

1 Like

I commented on your bug submission.

The update has been released. I installed it and now I can set my refresh rate and it also holds after a reboot.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.