Monitor loses video signal after boot, screen stays black

I have since my last update the problem (I think latest kernel and radeon driver where updated) that when booting before the DM starts: The monitor loses its video signal.

I already tried to enter the TTY with CTRL+ALT+F2(F3/F4/F5) but that doesn’t seem to work either, the screen stays black.

If all goes well here is a video:

What else can I try here?

Thank you in advance,


Try chroot using the installation medium USB and install LTS Kernel and headers.

Im Having the same Problem. Seems like a driver issue to Me. The live usb also does not want to work. Looks like Xserver does not find the drivers

If the video drivers are broken, you should try to boot to TTY straight from the boot menu, editing the boot entry and add 3 in the kernel parameters line (actual method depends on which bootloader is used, grub, systemd-boot, refind, etc.).

This shouldn’t be related to the current issue, which is supposed to relate to package updating). You may experience a different issue, so maybe create a new topic?

Done sorry

Oh man this is really strange.

I added to my kernel parameter line and finally am greeted by a TTY login. But one second later, before I can login, the screen goes black again.

I also have the original USB drive from the installation, after choosing the boot option it suddenly also boots into a dead screen.

Could you provide your hardware info. Post the link from this command.

inxi -Faz | eos-sendlog

If you are dual-booting with WinOS, go and disable Fastboot, hibernation and shutdown properly (Power off).

I was finally able to create another bootable USB device with Ubuntu.
The normal boot option would also send me to a black screen, but: the “safe graphics” option finally booted to the live system.

I could now chroot into my system and run a pacman -Syyu, but after a reboot my screen was again black.

So here is my inxi output with errors:

[root@ubuntu /]# inxi -Faz
  12Kernel 5.15.0-43-generic 12arch x86_64 12bits 64 12compiler N/A 12Console N/A 12Distro EndeavourOS
    12base Arch Linux
  12Message No machine data: try newer kernel. Is dmidecode installed? Try -M --dmidecode.
Can't use an undefined value as an ARRAY reference at /usr/sbin/inxi line 10498.

This doesn’t gives us any useful information. If you were able to arch-chroot and run an update this makes no sense that you can’t get the full output of the command. It is way longer than this which is basically one line. It 's asking if dmidecode is installed? You can install it or check if it’s installed. It should have been already installed.

Edit: We need to see the hardware output in order to be able to help.

1 Like

Okay, my bad. There is a difference between chroot and arch-chroot.
I had to install the Ubuntu package ‘arch-install-scripts’ which includes arch-chroot.

So I did a proper arch-chroot and this is the inxi output:

12Kernel 5.15.0-43-generic 12arch x86_64 12bits 64 12compiler gcc 12v 11.2.0
12parameters BOOT_IMAGE=/casper/vmlinuz nomodeset file=/cdrom/preseed/ubuntu.seed maybe-ubiquity
quiet splash ---
12Console N/A 12wm gnome-shell 12DM GDM3 12Distro EndeavourOS 12base Arch Linux
12Type Desktop 12Mobo ASRock 12model B550M-ITX/ac 12serial <filter> 12BIOS American Megatrends LLC. 12v P2.00
12date 09/30/2022
12Info 12model AMD Ryzen 5 5600 12socket AM4 12bits 64 12type MT MCP 12arch Zen 3+ 12gen 4 12level v3 12note check
12built 2022 12process TSMC n6 (7nm) 12family 0x19 (25) 12model-id 0x21 (33) 12stepping 2
12microcode 0xA20120A
12Topology 12cpus 1x 12cores 6 12tpc 2 12threads 12 12smt enabled 12cache 12L1 384 KiB
12desc d-6x32 KiB; i-6x32 KiB 12L2 3 MiB 12desc 6x512 KiB 12L3 32 MiB 12desc 1x32 MiB
12Speed (MHz) 12avg 2358 12high 3500 12min/max 2200/4467 12boost enabled 12base/boost 3500/4450 12scaling
12driver acpi-cpufreq 12governor schedutil 12volts 1.1 V 12ext-clock 100 MHz 12cores 121 2200 122 2800 123 2200
124 2200 125 2200 126 2200 127 2200 128 2200 129 2200 1210 2200 1211 2200 1212 3500 12bogomips 83850
12Flags avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
12Type itlb_multihit 12status Not affected
12Type l1tf 12status Not affected
12Type mds 12status Not affected
12Type meltdown 12status Not affected
12Type mmio_stale_data 12status Not affected
12Type spec_store_bypass 12mitigation Speculative Store Bypass disabled via prctl and seccomp
12Type spectre_v1 12mitigation usercopy/swapgs barriers and __user pointer sanitization
12Type spectre_v2 12mitigation Retpolines, IBPB: conditional, IBRS_FW, STIBP: always-on, RSB
12Type srbds 12status Not affected
12Type tsx_async_abort 12status Not affected
12Device-1 AMD Navi 23 [Radeon RX 6650 XT] 12vendor Gigabyte 12driver N/A 12arch RDNA-2 12code Navi-2x
12process TSMC n7 (7nm) 12built 2020-22 12pcie 12gen 4 12speed 16 GT/s 12lanes 16 12bus-ID 08:00.0
12chip-ID 1002:73ef 12class-ID 0300
12Display 12server 12v 12compositor gnome-shell 12driver 12X 12loaded amdgpu
12unloaded modesetting,radeon 12alternate fbdev,vesa 12dri radeonsi 12gpu N/A 12display-ID :0
12API OpenGL 12Message GL data unavailable for root.
12Device-1 AMD Navi 21/23 HDMI/DP Audio 12driver snd_hda_intel 12v kernel 12pcie 12gen 4 12speed 16 GT/s
12lanes 16 12bus-ID 08:00.1 12chip-ID 1002:ab28 12class-ID 0403
12Device-2 AMD Starship/Matisse HD Audio 12vendor ASRock 12driver snd_hda_intel 12v kernel 12pcie 12gen 4
12speed 16 GT/s 12lanes 16 12bus-ID 0a:00.4 12chip-ID 1022:1487 12class-ID 0403
12Sound API ALSA 12v k5.15.0-43-generic 12running yes
12Sound Server-1 PulseAudio 12v 16.1 12running yes
12Sound Server-2 PipeWire 12v 0.3.65 12running yes
12Device-1 Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 12vendor ASRock 12driver r8169
12v kernel 12pcie 12gen 1 12speed 2.5 GT/s 12lanes 1 12port f000 12bus-ID 04:00.0 12chip-ID 10ec:8168
12class-ID 0200
12IF enp4s0 12state down 12mac <filter>
12Device-2 Intel Dual Band Wireless-AC 3168NGW [Stone Peak] 12driver iwlwifi 12v kernel 12pcie 12gen 1
12speed 2.5 GT/s 12lanes 1 12bus-ID 05:00.0 12chip-ID 8086:24fb 12class-ID 0280
12IF wlp5s0 12state up 12mac <filter>
12Device-1 Intel Wireless-AC 3168 Bluetooth 12type USB 12driver btusb 12v 0.8 12bus-ID 1-9:5
12chip-ID 8087:0aa7 12class-ID e001
12Report rfkill 12ID hci0 12rfk-id 0 12state up 12address see --recommends
12Local Storage 12total 990.11 GiB 12used 90.58 GiB (9.1%)
12ID-1 /dev/nvme0n1 12maj-min 259:0 12vendor TeamGroup 12model T-FORCE TM8FP7001T 12size 931.51 GiB
12block-size 12physical 512 B 12logical 512 B 12speed 63.2 Gb/s 12lanes 4 12type SSD 12serial <filter>
12rev EGFM15.1 12temp 34.9 C 12scheme GPT
12SMART yes 12health PASSED 12on 28 hrs 12cycles 49 12read-units 271,339 [138 GB]
12written-units 271,568 [139 GB]
12ID-2 /dev/sda 12maj-min 8:0 12type USB 12vendor Intenso 12model Alu Line 12size 58.59 GiB 12block-size
12physical 512 B 12logical 512 B 12type N/A 12serial <filter> 12rev 2.00 12scheme GPT
12SMART Message Unknown USB bridge. Flash drive/Unsupported enclosure?
12ID-1 / 12raw-size 930.53 GiB 12size 914.85 GiB (98.31%) 12used 90.48 GiB (9.9%) 12fs ext4
12block-size 4096 B 12dev /dev/nvme0n1p2 12maj-min 259:2
12Alert No swap data was found.
12System Temperatures 12cpu 35.0 C 12mobo N/A
12Fan Speeds (RPM) N/A
12Processes 320 12Uptime 23m 12wakeups 0 12Memory 31.28 GiB 12used 2.59 GiB (8.3%) 12Init systemd 12v 252
12default graphical 12tool systemctl 12Compilers 12gcc 12.2.1 12Packages 12pm pacman 12pkgs 990 12libs 279
12tools yay 12Client Unknown Client: systemd 12inxi 3.3.25
12Device-1 AMD Navi 23 [Radeon RX 6650 XT] 12vendor Gigabyte 12driver N/A 12arch RDNA-2 12code Navi-2x

Can you give me also this to confirm?

inxi -Ga


It’s been so long i have forgotten most of the previous issue. Are you able to boot on the live ISO? Or it is installed and you can’t boot?

On the live ISO you need to add this kernel parameter and try. If it works you could install. Once installed you would need to add this kernel parameter to the default grub command line if you install with grub. Then grub needs to be updated also. For now i don’t know the details as it’s been too long.


Hey @ricklinux,

thanks for your patience, yeah you are right this was really a dragging process as I mostly have an hour in the evening to deal with this.

I may resolved this, have to do some more testing later.

So I try to brake this down, maybe it’s helping someone who runs into this problem.

  • After update the EOS system could not boot into the DM, no cursor, monitor loses signal.

  • The same install medium that was used for installing my system could also not boot into a live system, same problem (still a ??? for me)

  • So I opted for another distribution to boot into a live system, the latest Ubuntu.

  • Same behavior, but booting the “safe graphics” mode finally worked.

  • Here I could arch-chroot into my system after installing the Ubuntu package ‘arch-install-scripts’ which includes arch-chroot (arch-chroot script does apparently way more than a chroot, learned that)

  • Run pacman -Syyu and the system boots normally again…

Lessons learned: Move ASAP to BTRF + timeshift to prevent a total lockout. This combination works flawless on my notebook. :smiling_face_with_tear:

Thank you all for your input!

1 Like

Well at least you were able to arch-chroot another way and update which fixed the problem. I don’t know if it was a partial update previously that caused the problem but that would be my guess. I’ve never run into these kind of issues but there’s always tomorrow. Glad it’s working for you.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.