Display Manager stopping monitor signal instead of showing login screen

I’ve been happily using EndeavourOS for about 3 weeks now until last week where I suddenly hit an issue with one of my monitors. It works fine once I’ve logged in, except that when the login screen should appear, the monitor says there’s no signal coming from the computer.

EDIT: After some more testing, startx on ctrl+alt+F3 seems to open something rather than crash which could point to a display manager issue?

It looks exactly like this:

Except unlike their issue, I can get into TTY fine (so far…)

Hardware info:


Screen 0: minimum 320 x 200, current 2560 x 1440, maximum 16384 x 16384
DisplayPort-0 disconnected (normal left inverted right x axis y axis)
DisplayPort-1 disconnected (normal left inverted right x axis y axis)
DisplayPort-2 disconnected (normal left inverted right x axis y axis)
HDMI-A-0 disconnected (normal left inverted right x axis y axis)
DisplayPort-4 connected primary 2560x1440+0+0 (normal left inverted right x axis y axis) 553mm x 311mm
   2560x1440     59.95*+
   2048x1152     60.00
   1920x1200     59.88
   1920x1080     60.00    50.00    59.94    30.00    25.00    24.00    29.97    23.98
   1600x1200     60.00
   1680x1050     59.95
   1280x1024     75.02    60.02
   1200x960      59.99
   1152x864      75.00
   1280x720      60.00    50.00    59.94
   1024x768      75.03    60.00
   800x600       75.00    60.32
   720x576       50.00
   720x480       60.00    59.94
   640x480       75.00    60.00    59.94
   720x400       70.08
DisplayPort-5 disconnected (normal left inverted right x axis y axis)
HDMI-A-1-1 disconnected (normal left inverted right x axis y axis)
DisplayPort-1-3 disconnected (normal left inverted right x axis y axis)

KScreen info about the monitors (found in ~/.local/share/kscreen/outputs):
My main monitor/the one with the issue (somehow there’s 3 of this with different IDs in the folder, but one has HDMI instead of DP-4 so I’m assuming it’s settings based on when I was checking with different cables):

    "id": "5b6c657959fca2bc8ba313266943aa2d",
    "metadata": {
        "fullname": "xrandr-Dell Inc.-DELL U2515H-9X2VY4CB0JML",
        "name": "DisplayPort-4"
    "mode": {
        "refresh": 59.9505500793457,
        "size": {
            "height": 1440,
            "width": 2560
    "overscan": 0,
    "rgbrange": 0,
    "rotation": 1,
    "scale": 1,
    "vrrpolicy": 2

The Philips one mentioned later:

    "id": "9fd670836e4e99e9ac6db9c7f7bdec41",
    "metadata": {
        "fullname": "xrandr-Philips Consumer Electronics Company-Philips 222E-DL21102103755",
        "name": "HDMI-A-0"
    "mode": {
        "refresh": 60,
        "size": {
            "height": 1080,
            "width": 1920
    "overscan": 0,
    "rgbrange": 0,
    "rotation": 1,
    "scale": 1,
    "vrrpolicy": 2

Things I’ve tried:

  • Turning off screen energy saving and suspend session in the power management settings
  • Comparing journalctl results from a successful login and one that only resulted in a black screen (couldn’t see any difference, and any errors/warnings that were there happened on both, it just looked like I wasn’t seeing the login screen for some reason)
  • ctrl+alt+F3 and ctrl+alt+F1 worked fine, but using xrandr to see the monitors returned “can’t open display” (I think this is because Xorg isn’t running…? But I’m a noob so I was a bit confused on how to fix it)
  • Disabling KScreen 2 on startup/shutdown (no difference, ended up turning it back on)
  • Plugging in a second monitor and booting (both were black)
  • Switching cables (I’ve tried HDMI, mDP and DP all on the same monitor but there doesn’t seem to be any change.)
  • Switching ports (no difference which DP port I use, it’s all still giving no signal)
  • Restarting the computer several times (The first time, 3 normal boots and 1 fallback boot worked. The second time, I alternated fallback and normal, the normal one worked on the 4th boot. The third time, I hit 7 alternating boots but nothing seemed to do anything.)
  • Waiting several minutes (no change)

My current solution:

  • Turn on computer with only the Philips monitor connected (via HDMI), log in as normal, then plug in the Dell one (via DP) and use KScreen to confirm the main monitor is the Dell one (it seems to default to this anyways based on what xrandr tells me when they’re both plugged in) before unplugging the Philips one. The issue is the Philips monitor is borrowed so I need to find a solution that doesn’t involve using it!

Things that may or may not be related:

  • Previously there was one instance of the Dell monitor not waking up from suspend, but after restarting the computer it was fine. This is also the reason I turned off suspend.
  • The last thing that happened before this issue was a game crashing, forcing a restart, which ended up in a BIOS loop since it couldn’t see anything in the boot menu nor my storage. Shutting down, waiting a minute, then restarting showed the boot menu as normal, but it took a few more restarts before I could see the login screen again. (See: the “Restarting the computer several times” section from above.) I don’t have any logs for what caused this crash as Steam doesn’t automatically keep logs? However I’ve been able to play the game fine since.

I’m assuming this is some sort of issue with loading the display manager but I don’t know why that’d be exclusive to one monitor unless it’s related to the different resolutions?

If you’re able to access the command line, what I would try in your place is to do a system update with sudo pacman -Syu. Maybe some updated package has a serious bug, and the update might fix that.

And welcome to the EOS forum :slight_smile:

1 Like

Is there a difference between running yay and sudo pacman -Syu? Because I’ve been running yay daily in the hopes one of the packages fixes itself, but does yay not sort of include the -Syu part by default?

Also thank you! :smiley:

sudo pacman -Syu does not update the packages that have been installed from the AUR.
yay updates everything including packages from the AUR (and yes, no need to type “yay -Syu” or something).

Updating with yayshould do the trick, too. I am not so tech-savvy and I might be wrong, but in any case of emergency, or technical problems, or hurry, or slow internet connection, I prefer to use sudo pacman -Syu. Maybe someone experienced can tell me: Is that good-case practice, or is it better to just always use yay?

Unfortunately running yay didn’t fix the issue even though there were some potentially useful updates yesterday… I did discover that running startx works (based on this tutorial here [FAQ] Computer doesn’t boot, boots to a black screen, or stops at a message, it showed 3 white console-type boxes for me and when I quit there were no errors/(EE)s in the log.) I’ve updated the post accordingly.

Tried having KMS start early (based on this https://wiki.archlinux.org/title/Kernel_mode_setting#Early_KMS_start, except I had to follow what was here https://discovery.endeavouros.com/installation/dracut/2022/12/ since I have dracut instead) and that somehow made the situation worse. The ‘dracut’ part of the scrolling text on boot happened but the main part + tty no longer appeared. Ended up using the second/Philips monitor and rebooting which… Somehow worked again? But I ended up undoing all of that immediately anyways due to the second monitor having strange visual glitches.

Regardless, my current solution is using TTY and systemctl restart sddm which works… No clue why, but it’s still only a half solution.