Missing AUR Packages: ipw2100-fw ipw2200-fw

ipw2100-fw and ipw2200-fw have been removed from the repos.

They are firmware for the following older Intel wireless devices:

  • Intel PRO/Wireless 2100 802.11b chipset.
  • Intel PRO/Wireless 2200 802.11bg and 2915 802.11a/bg chipsets.

Unless you have that hardware in your machine, you can safely remove both packages.

They can be removed with the command:

sudo pacman -R ipw2100-fw ipw2200-fw


joe edit:
some details about identify your hardware:

18 Likes

i have Intel chipset and I am getting this notice.

$ yay -Syu ipw2100-fw  ipw2200-fw
 -> Missing AUR Packages:  ipw2100-fw  ipw2200-fw
 -> Could not find all required packages:
	ipw2100-fw (Target)
	ipw2200-fw (Target)

That solved my problem thanks!

If you have one of those specific devices listed in the initial post, you need to keep the related firmware.

If not, you can remove them.

i dont have them, but whenever i run yay, i am getting the above notice and i cant install them.

Did you read the initial post? It describes exactly what command to run if you don’t have that hardware.

what i meant by i dont have them is, the packages (because i did not install them). but i am wrong. i have the packages.

so when i ran pacman -R , it removed the packages. So if i really had that specific firmware, i have to live with the missing package notice, all my life ?

partial inxi -Fx CPU: Info: dual core model: Intel Core i5-5300U bits: 64 type: MT MCP arch: Broadwell rev: 4 cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB Speed (MHz): avg: 2573 high: 2842 min/max: 500/2900 cores: 1: 2842 2: 2570 3: 2586 4: 2295 bogomips: 18361 Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx

1 Like

No, someone will probably add to them to AUR at some point.

They only just were removed from the repos.

3 Likes

Not sure if this will be helpful to anyone, but Archive.org user Arch Linux appears to have backups of both of these.

ipw2100-fw

ipw2200-fw

1 Like

@dalto

So how do we bypass these packages on a fresh install from the live ISO?

2022-09-22 - 12:21:53 [6]: [PYTHON JOB]: "error: target not found: ipw2100-fw" 
2022-09-22 - 12:21:53 [6]: [PYTHON JOB]: "error: target not found: ipw2200-fw" 
1 Like

For now, just uncheck them.

The team is working on a hotfix.

4 Likes

Okay … i didn’t realize they were in the package list. Didn’t think about looking there first. My bad!
Thanks! :smile:

1 Like

Just an idea until there is a fix/new iso:

Throw them into the EOS repo…

PKGBUILD’s are still out there:

2 Likes

The hotfix should be live now. @joekamprad made it happen.

7 Likes

The HotFix from the U-Bahn :wink:
2022-09-22_19-15

11 Likes

https://fedoraproject.org/wiki/Changes/RemoveWirelessExtensions

Is giving info on why they are removed on arch now also…

3 Likes

Ya… who uses wep? That’s like leaving the door open. :stuck_out_tongue_winking_eye:

wifi … :cloud: :wind_face: use cables :electric_plug:

Cat 6a for me!

Screenshot_20220922_135951

1 Like