Matlab installation does not generate build files

I am trying to install matlab and when I run yay -S matlab

it says that my build files exist, but it also says the following:

ls: cannot access '/home/.cache/yay//matlab/src/build': No such file or directory
==> ERROR: MATLAB installer failed, check install.log

Any idea what might cause this?

Reading install.log does not really tell me much, other than my destinationFolder being the one that is not found.

Edit: Explaining the situation with yay instead of arch wiki

Welcome to the purpel side :enos:
why not using yay ? it is preinstalled on EndeavourOS
It is a simple to use AUR helper:

yay -S matlab

1 Like

Thank you :enos: I am liking it so far!

I run in to the same problem when I use yay. I have put matlab.tar, matlab.lic and matlab.fik into home/.cache/yay/matlab but I still get the same issue. It says that build files exist when I run yay -S matlab, but then I get an error saying that they don’t.

Please post the complete output from yay -S matlab until the installation stalls. - Did you say A for all packages to be rebuilt?

Thank you.

1 Like

Hello, I solved this by following Matlab installation issues. I didn’t have time to post that yet, sorry.

Thanks for the help nonetheless!

1 Like

Please, don’t rename the thread to “Solved”. Instead, mark the answer that shows the solution as such. - Thanks. :wink:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.