Matlab installation issues

Hi everyone,

I used to use Antergos and since the project was discontinued, I am trying EndeavourOS and it has been working fine so far. However, I can’t install Matlab, neither 2019a nor 2018b versions. I am downloading the installer from mathworks (mainly because the license is from the university) and trying to install. At some random point the installer will quit with a message:

/tmp/mathworks_1700/bin/glnxa64/install_unix, linha 924: 1832 Morto “/tmp/mathworks_1700/sys/java/jre/glnxa64/jre/bin/java” -Xmx512m -splash:"/home/danielc/Downloads/matlab/java/splash.png" -cp /tmp/mathworks_1700/java/config/professionalinstaller/pathlist.jar com/mathworks/professionalinstaller/Launcher -root “/home/danielc/Downloads/matlab” -libdir “/tmp/mathworks_1700” 2> /dev/null

(linha is line and morto means dead)

Some information regarding specs and stuff:

  1. This is an old Dell Vostro, i5 and 6gb ram.
  2. It is dual booted with windows 10. Both systems work fine.
  3. Matlab installer downloads everything to temp, so I had to increase the tempfs. I used the following command:

sudo mount -o remount,size=10G,noatime /tmp

  1. After that, I am using sudo to run the installer

Has anyone been able to install matlab through their installer? I remember installing it on Antergos with almost no headaches.

I apologize if I posted on the wrong place or this has been already discussed somewhere, and I will gladly share more info if it is need

Thanks in advance!

hi welcome.

and java is installed?.

you installed it by a installer from there source. Just want to know , i just wonder if you used the aur version ?

java is installed?

From Arch Wiki, I understood it was not necessary:

The MATLAB installation software is self contained and does not require any additional packages to install in silent mode. To install with the GUI a working Xorg graphical display is necessary. Wayland is not currently supported yet. The installation is handled by the install script. You can run the script as root to install MATLAB system-wide or your user to install it only for you.

I checked and I have Xorg. I tried installing Java and it didn’t work either

the aur version

I will try it. However, I am trying to avoid it since I have no idea if it will generate any problem on activation. And since I have installed this before on Antergos, I was not expecting this kind of problem. Maybe I am just a little stubborn on this one…

Thanks!

I’ve solved it, and @ringo suggestion proved valuable. I will describe it step by step and hopefully I will be the last person to spent a day and a half trying to solve it. Here it goes:

  1. Download it from the mathworks website and unpack it
  2. Install jre8-openjdk.
  3. Open a terminal where you unpacked it and run the following:
sudo ./install -javadir /lib64/jvm/java-8-openjdk/jre
  1. Go through the steps until the one to select what should be downloaded
  2. Download only Matlab, Optimization, Symbolic and Stats and ML add-ons (if you want this addons). Downloading too many addons leads to a complete frozen system in my case, and the only way to get out was a hard reboot

This worked here without any surprises, but with the downside of only being able to install a small number of add ons

EDIT: You can rerun the installer using the command above and install whatever you want. This worked fine here.

1 Like