MATE Panel is out of date, causing a bug


I installed EndeavourOS MATE tonight and it’s mostly going very well. However, there is a glaring issue -the MATE panel is out of date with 1.24.0. This causes an issue where I cannot add an application launcher - it is grayed out as you can see here:


Is it possible to bundle the latest panel? Is it also possible in my current case to install the latest panel and set it up? If so, how?

Welcome to the forum. :beers:

Have you tried doing a full system update to see if a new version gets pulled in? You can do it from the welcome screen or with

sudo pacman -Syu
or just

in the terminal.


I just checked the install I did of MATE last night, and it works fine. I did run an update as described above after the installation, though.

I did try this yes, just ran yay. It didn’t fix the issue. Last night I did upgrade the panel itself with sudo pacman -S mate-panel but this did not fix the issue either.

Running pacman -Si The panel version is 1.24.0-1 which should have fixed the bug, yet my panel shows as 1.24.0 in the about section and sitlll has the error.

It’s not normally the case in my limited experience, but it might take a reboot or at least logging out and back in, in order for the changes in the new version to kick in. Give it a try and see. Outside of that I have to default to somebody with more experience in MATE. :crossed_fingers:

Just rebooted, did not fix the issue.

Also I apologize for not checking more information in the OP and posting it in the MATE section.

I can move the post to the mate de section if you would like.

If that would be the proper thing to do then yes, please do so and thank you very much.

OK and BTW

1 Like

in its stil 1.24.0-1 is the mate-panel not locked ? (right click on the panel)

if thats locked you cannot add stuf ?

I don’t see any lock for the panel itself.

This is a long shot. My Mate install works with 1.24.0-1. The one thing I noticed between my Add to Panel and yours was a different theme & different icons.

I am using BlackMATE and it works perfect. Try going to Appearances and change to BlackMATE and see what you get. Probably won’t fix it but I have seen where a theme will mess with certain features. What the heck, give it a whirl.



I like the logic - and I chose BlackMATE too on the one I set up a couple of days ago to test :grin: I have to do too much thinking to customizing it, though… I’m trying NOT to bring half of XFCE along with me just to make it ‘comfortable’…trying - not necessarily succeeding!


I tried BlackMATE, the Add button was still greyed out because it wouldn’t actually let me select anything. Same deal with BlueSubmarine and a few others I tried.

Also I’m pretty sure that 1.24.0-1 is supposed to have this fixed cause looking online that was supposed to fix the bug. I do have it installed, though About Panels only shows 1.24.0. Can someone else check if their About Panels also shows this?

What about checking that your local environment files are owned properly ( could be an issue if you’ve been moving things around using another user, eg root)? If they are not it would mean that things were read-only.
sudo chown username:username /home/username -R
should do it, where username is yours.

I tried this to no avail, not even after reboot.

Screenshot at 2020-07-20 09-47-09
FYI: About panels versus PAMAC version number.
Just loaded Mate to play with this. Pleasantly surprised; it’s been a long time since I last used it.

mate-panel --reset & mate-panel --layout mint.layout

Try this?

Still no luck at all.

Version seems correct? -1 number are rel numbers not mate versioning, is about packaging. Or little bugs fix