Macbook Pro 2015 Wifi not detected


I installed EndeavourOS on my Macbook Pro 2015 and I cannot see my home wifi network to connect. I did not have this issue on my Macbook Air and am wondering if I can get some help here.

For starters, I went through this post:

I first installed the following packages :

pacman -S linux-headers
pacman -S broadcom-wl-dkms
pacman -S dkms

Still couldn’t detect wifi networks after a reboot.

Next I tried to install and reboot but to no avail :

pacman -S broadcom-wl

Some additional details from the terminal:

pacman -Qs broadcom
    Broadcom 802.11 Linux STA wireless driver

lsmod | grep wl
wl                   6524928  0
cfg80211             1064960  1 wl

rfkill list
0: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp0s20u1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN mode DEFAULT group default qlen 1000
    link/ether 1a:5e:5e:6f:d2:bb brd ff:ff:ff:ff:ff:ff

inxi -Nx
  Device-1: Broadcom BCM43602 802.11ac Wireless LAN SoC vendor: Apple
    driver: N/A bus-ID: 03:00.0

Please let me know if there are other commands I’ll need to run and paste the output for.

Thanks for any help provided by kind strangers!

It should work on the broadcom-wl or broadcom-wl-dkms. Are you using the current kernel or lts?

Try reinstalling



1 Like

Thanks for the response. But I already tried that and it didn’t work. I will post what worked for me and close this. Thanks again!

Edit: I am using the kernel that comes with fresh install.

This solution worked for me!

Okay … looks like this chip is using the kernel module. Glad you got it working.

Edit: I have the BCM4360 802.11 AC and it does use the broadcom-wl-dkms

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.