LXQT without Num-Lock enabled from the start

Hello!

Someone knows how to make LXQT from the beginning, enable Num-Lock, since it doesn’t and make it manual, it’s not a problem, now; it would be good if it is already enabled when starting the DE.
As always, thanks !

Would package numlockx help?

1 Like

Now I see…

Are you using lightdm? If so,

### NumLock on by default  (Edited: numlockx is in the repos)

Install the numlockx package and then edit `/etc/lightdm/lightdm.conf` :

/etc/lightdm/lightdm.conf

[Seat:*] greeter-setup-script=/usr/bin/numlockx on

From the ArchWiki:
https://wiki.archlinux.org/index.php/LightDM#NumLock_on_by_default

1 Like

I installed the package, restarted it and it doesn’t work.

I did, I rebooted and it doesn’t work:

Does the # mean ignore this line?

1 Like

You haven’t removed the # in front of the line so that means it’s ignored.

1 Like

I use lxdm, but use numlockx in auto start, if you use sddm, in aur you have sddm-conf or editor…is from lxqt but is not in main…’, you can set in that way the greeter you want to use and enable of disable numlock. But changing greeter need to enable it again :grin: ik believe the new compton is noW picaw? If you use comp-conf in aur you get in lxqt session componton option enable disable with comp-conf you config composition

1 Like

Phew, I forgot to comment :frowning: , sorry and thank you !

If you do numlockx is standard default to on :slight_smile:

1 Like

decomment problems with the translator …

1 Like

@manuel @Tiedemann @CMarch @ringo

Well, with the whole #discussing thing, it wasn’t as easy as it seemed…

In Arch’s wiki, there is a big part of the solution, here: https://wiki.archlinux.org/index.php/Activating_numlock_on_bootup


Also here:

In this last part of /etc/sddm.conf → there is a problem.

Why ?

The file is different in the wiki, as you can see in the screenshot:
SDDM
In the file /etc/sddm.conf, under the [General] section, set Numlock value to on :

[General]
...
Numlock=on

When I do all the steps, I reboot and I find that it still doesn’t turn on the Num-Lock led, then I see that where it says [General] it says [Autologin], then I replaced Autologin by General and when I reboot everything started working, it turned on the led and that was it.

[judd@judd-pc ~]$ cat /etc/sddm.conf → Fake
[Autologin]
Session=lxqt

[judd@judd-pc ~]$ cat /etc/sddm.conf → True
[General]
Session=lxqt
Numlock=on

Translated with www.DeepL.com/Translator (free version)

Oh yeah that is it to much used to sddm conf lol

1 Like

Before, yes, now it seems that there to change it! :wink:

Oh, I forgot …
As a matter of fact, thank you very much to all those who participated very quickly in creating this thread! :slight_smile:

1 Like

For me easier would be to change the setting in Uefi bios to boot with Num-Lock on. :laughing:

Edit: Maybe it doesn’t work either? :thinking:

1 Like

Totally and absolutely → DOES NOT WORK

1 Like

I guess it only works in Windows.

Yes of course, in LXQT I had to work on it, but in other DE it’s not the same, they work when you start the chosen desktop.

So it’s just LXQT then? Probably same on OpenBox then?