Lost NTFS partition

Hello,
I have dual boot with EOS and Win10. Two separate drives. One 500GB NVMe shared with Win10 boot and system and one 1TB HDD for stuff. So, one of the logical partitions from the HDD I was using for extra storage while in EOS.
In this particular case I was downloading using qBitorrent to the “missing” partition. The system froze. No response from keyboard, mouse… I did hard restart and when I logged in EOS the drive/partition was missing.
So far I used KDE Partition Manager to figure out what’s going on. Couldn’t mount

No mount


And Disk check came back with error:

KDE Partition Manager: SMART Status Report
Date: 2024-04-15 12:15 P.M.
Program version: 24.02.2
Backend: pmsfdiskbackendplugin (1)
KDE Frameworks version: 6.0.0
Machine: Linux EVL340 6.8.5-arch1-1 #1 SMP PREEMPT_DYNAMIC Thu, 11 Apr 2024 01:47:33 +0000 x86_64

Check and repair partition ‘/dev/sda1’ (931.51 GiB, ntfs)
Job: Check file system on partition ‘/dev/sda1’
Command: ntfsresize --no-progress-bar --info --force --verbose /dev/sda1
Check file system on partition ‘/dev/sda1’: Error
Check and repair partition ‘/dev/sda1’ (931.51 GiB, ntfs): Error


Also, I logged in Win10 and confirmed the partition is well and alive. No issue accessing the partition in Win10. All data intact.

So, being a noob I exhausted my knowledge what to do.
Help will be appreciated.
Thanks

Do you have “fast startup” disabled in windows? If you don’t disable that, the disks will always be marked as dirty since Windows is going into a hybrid shutdown state.

2 Likes

if it is not a fast startup issue of Windows
you can do an
fdisk -l to see how
the HD are mounted, or you could also
post a view of a partition manager like
gparted or KDE part man.

also interesting how your /etc/fstab looks like.

I cannot recall right now, since I’m in EOS. Haven’t touched/changed it. But it was mounted before the hard shutdown. Actually, after the initial EOS installation many months ago the EOS automatically found and mount the partition. Access with sudo password.

If it’s of any help, fast startup option might be found in the BIOS/UEFI menu.

(others feel free to correct me if I’m wrong, I’m also a newbie lol)

it is a setting in windows energy management settings

That is Fast Boot which is something different despite the similar name.

1 Like

Thats what I get in return:

[panta@EVL340 ~]$ fdisk -l
fdisk: cannot open /dev/sda: Permission denied
fdisk: cannot open /dev/nvme0n1: Permission denied
[panta@EVL340 ~]$

sorry I ment

sudo fdisk -l

Disk /dev/sda: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: WDC WD10SPZX-24Z
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 64607383-1719-4DBC-8B9E-FD7F2E3E4051

Device Start End Sectors Size Type
/dev/sda1 2048 1953521663 1953519616 931.5G Microsoft basic data

Disk /dev/nvme0n1: 465.76 GiB, 500107862016 bytes, 976773168 sectors
Disk model: WDC WDS500G2B0C-00PXH0
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: C1B9245B-F5DA-4BA4-B948-374D7B389C65

Device Start End Sectors Size Type
/dev/nvme0n1p1 2048 206847 204800 100M EFI System
/dev/nvme0n1p2 206848 239615 32768 16M Microsoft reserved
/dev/nvme0n1p3 239616 766019693 765780078 365.2G Microsoft basic data
/dev/nvme0n1p4 975730688 976771071 1040384 508M Windows recovery environment
/dev/nvme0n1p5 766019694 782794751 16775058 8G Linux swap
/dev/nvme0n1p6 782794752 866680831 83886080 40G Linux filesystem
/dev/nvme0n1p7 866680832 975730687 109049856 52G Linux home

Partition table entries are not in disk order.

Try going to windows, then fully shutting the system down from there (not restart!) then cold boot into linux, see if that fixes it.

Also make sure any windows boot shenanigans like fast startup and hibernation are disabled.

If that doesn’t do the trick, try ntfsfix, I believe it’s a part of the ntfs-3g package or something like that, it is probably already installed for u so u just gotta run it and point it at ur partition.

Honestly in my years of experience on linux, dual booting through most of it, using ntfs on linux is a mistake to be avoided. This kind of shit is just one of many, many reasons.

Also, also, avoid KDE Partition Manager (like the plague!) everytime i tried to shrink a volume with it, it got corrupted, but it has never happened to me when i used gparted.

and now the content of ?
/etc/fstab
you can get it with

cat /etc/fstab

!! but you need to be sure first that like @dalto mentioned
you turn of fast startup mode in Windows energy saving settings

That was OFF. Grayed out.
fast startup

/etc/fstab: static file system information.

Use ‘blkid’ to print the universally unique identifier for a device; this may

be used with UUID= as a more robust way to name devices that works even if

disks are added and removed. See fstab(5).

UUID=74C8-4807 /boot/efi vfat noatime 0 2
UUID=1637e96b-5ade-41b9-b984-ad229771ac69 / ext4 noatime 0 1
UUID=7721bf1f-7343-4d4e-a540-8bc6b5222001 /home ext4 noatime 0 2
UUID=30A494F1A494BB34 /dev/sda1 ntfs defaults 0 0

perfect :slight_smile: , now we can carry on at:

cat /etc/fstab

it seems to me here is the problem.

Yep, I saw it, too.
Now what?

hang on I am working on it

in the console:

sudo mkdir /media
sudo mkdir /media/mydisk

replace these two lines in /etc/fstab like this:

#UUID=30A494F1A494BB34 /dev/sda1 ntfs defaults 0 0
UUID=30A494F1A494BB34  /media/mydisk ntfs rw 0 0

then in the console:

sudo mount -a

… assuming that the UUID matches to sda1 (?)
if not we can work around with
/dev/sda1 /media/mydisk ntfs rw 0 0
since there is no other sd - device to confuse with